杭电acm 3613Best Reward(字符串)

时间:2023-01-03 16:47:40

Best Reward

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/65536K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit. 

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.) 

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li. 

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero. 

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value. 

Input

The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows. 

For each test case, the first line is 26 integers: v1, v2, ..., v26 (-100 ≤ vi ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind. 

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v1, the value of 'b' is v2, ..., and so on. The length of the string is no more than 500000. 

Output

Output a single Integer: the maximum value General Li can get from the necklace.

Sample Input

2
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
aba
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
acacac

Sample Output

1
6

Source

2010 ACM-ICPC Multi-University Training Contest(18)——Host by TJU

题目大意:

字母表的26个字母都有一个价值,给你一个字符串,将该字符串切成两份,对于每一份,如果是回文串,就获得该子串的字母价值

之和,否则该子串的价值为0。求出将字符串切成两份后能够获得的最大价值。

想法:

先用Manacher算法求出以每个字母为中心的回文串的长度,并计算该字符串的前缀价值和。然后枚举切割点,得到两份

子串。这样就可以知道每个子串的中心点,然后检查以该子串的中心点作为中心点的回文串的长度,如果长度等于该子串的长度,

那么就加上该子串的价值。然后和最优价值比较就行了。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=5e5+5;
char s[maxn],t[maxn<<1];
int p[maxn<<1];
int a[maxn],v[26];
void manacher()
{
    int len=strlen(s),l=0;
    t[l++]='$';
    t[l++]='#';
    for(int i=0;i<len;++i)
    {
        t[l++]=s[i];
        t[l++]='#';
    }
    t[l]=0;
    int maxx=0,num=0;
    for(int i=0;i<l;++i)
    {
        p[i]=maxx>i?min(p[2*num-i],maxx-i):1;
        while(t[i+p[i]]==t[i-p[i]])p[i]++;
        if(i+p[i]>maxx)
        {
            maxx=i+p[i];
            num=i;
        }
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        for(int i=0;i<26;++i)
            scanf("%d",&v[i]);
        scanf("%s",s);
        int l=strlen(s);
        a[0]=v[s[0]-'a'];
        for(int i=1;i<l;++i)
        {
            a[i]=a[i-1]+v[s[i]-'a'];
        }
        manacher();
        int ans=0;
        for(int i=0;i<l-1;++i)
        {
            int tmp=0;
            int num=p[i+2]-1;
            if(num==i+1)//前缀是不是回文
                tmp+=a[i];
            num=p[i+l+2]-1;
            if(num==l-i-1)//后缀是不是回文
                tmp+=a[l-1]-a[i];
            if(tmp>ans)
                ans=tmp;
        }
        printf("%d\n",ans);
    }
    return 0;
}