POJ 1650 Integer Approximation

时间:2024-01-06 16:47:44
Integer Approximation
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5081   Accepted: 1652

Description

The FORTH programming language does not support floating-point arithmetic at all. Its author, Chuck Moore, maintains that floating-point calculations are too slow and most of the time can be emulated by integers with proper scaling. For example, to calculate the area of the circle with the radius R he suggests to use formula like R * R * 355 / 113, which is in fact surprisingly accurate. The value of 355 / 113 ≈ 3.141593 is approximating the value of PI with the absolute error of only about 2*10-7. You are to find the best integer approximation of a given floating-point number A within a given integer limit L. That is, to find such two integers N and D (1 <= N, D <= L) that the value of absolute error |A - N / D| is minimal.

Input

The first line of input contains a floating-point number A (0.1 <= A < 10) with the precision of up to 15 decimal digits. The second line contains the integer limit L. (1 <= L <= 100000).

Output

Output file must contain two integers, N and D, separated by space.

Sample Input

3.14159265358979
10000

Sample Output

355 113
题目大意:给出一个数字x和一个范围,在这个方位内招两个数字,是它们的商最接近x。
解题方法:直接枚举,取a,b为1每次对a,b求商,如果a / b > x,则a增加1,否则b增加1,每次记录下差值最小时a,b的值。
#include <stdio.h>

int main()
{
double x, a, b, n, Min, n1, n2;
scanf("%lf%lf", &x, &n);
a = ;
b = ;
Min = n + ;
while(a <= n && b <= n)
{
if (a / b > x)
{
if (a / b - x < Min)
{
Min = a / b - x;
n1 = a;
n2 = b;
}
b++;
}
else
{
if (x - a / b < Min)
{
Min = x - a / b;
n1 = a;
n2 = b;
}
a++;
}
}
printf("%.0f %.0f\n", n1, n2);
return ;
}