Time Limit: 4000MS | Memory Limit: 65536K | |
Total Submissions: 41515 | Accepted: 10932 |
Description
You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.
Input
The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.
Output
If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.
Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5
Sample Output
Twin snowflakes found.
题意
有n片雪花,问是否有两片完全相同呢? 雪花都是六棱的,如果六棱的长度对应完全相等,则认为两片雪花相同。
#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;
int maxn=90001;
struct sn{
int l[13];
int next;
}s[100005];
int h[90002],sum[100005];
int hash(int num){//return关键字,下标
return num%maxn;
}
void insert(int *b,int key,int i){//插入哈希表
int j;
for(j=1;j<=6;j++){
s[i].l[j]=s[i].l[j+6]=b[j];
}
s[i].next=h[key];//链地址法
h[key]=i;
}
int search(int *b,int key){//判断b是否与哈希表中的一片雪花相同
int i,t,f;
t=h[key];
while(t!=0){
for(f=0;f<6;f++){
for(i=1;i<=6;i++){
if(b[i]!=s[t].l[f+i]) break;
}
if(i==7) return 1;
for(i=1;i<=6;i++){
if(b[7-i]!=s[t].l[f+i]) break;
}
if(i==7) return 1;
}
t=s[t].next;
}
return 0;
}
int main(){
int i,j,n,key,flag=0,b[7];
scanf("%d",&n);
memset(h,0,sizeof(h));
memset(sum,0,sizeof(sum));
for(i=1;i<=n;i++){
for(j=1;j<=6;j++){
scanf("%d",&b[j]);
sum[i]+=b[j];
}
if(flag==1) continue;
key=hash(sum[i]);
if(search(b,key)==1){
flag=1;
}
else{
insert(b,key,i);
}
}
if(flag==1)
printf("Twin snowflakes found.");
else
printf("No two snowflakes are alike.");
return 0;
}