PAT 1042. 字符统计(20)

时间:2022-12-20 12:14:07

1042. 字符统计(20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:
This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........
输出样例:
e 7

提交代

#include <iostream>
#include<string.h>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    char a[1010];
    int d[130]= {0};
    gets(a);
    int la=strlen(a);
    for(int i=0; i<la; i++)
    {
        if(a[i]>='A'&&a[i]<='Z')
            a[i]+=32;
        if(a[i]>='a'&&a[i]<='z')
        {
            d[a[i]]++;///d[a[i]-0]也对,d[a[i]-'0']不对
        }
    }
    int maxx=0;
    int id=-1;
    for(int i=96; i<=122; i++)
    {
        if(d[i]>maxx)
        {
            maxx=d[i];
            id=i;
        }
    }
    printf("%c %d",id,maxx);
    return 0;
}

当知道maxx的下标id=i值后求所对应的元素e时候你遇到了困难,傻逼吗,直接强制类型转换