HDU 1863:畅通project(带权值的并查集)

时间:2024-01-03 16:42:50

畅通project





Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 16075    Accepted Submission(s): 6677

Problem Description
省*“畅通project”的目标是使全省不论什么两个村庄间都能够实现公路交通(但不一定有直接的公路相连,仅仅要能间接通过公路可达就可以)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编敲代码,计算出全省畅通须要的最低成本。
Input
測试输入包括若干測试用例。每一个測试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N


行相应村庄间道路的成本,每行给出一对正整数,各自是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,所有输入结束,相应的结果不要输出。
Output
对每一个測试用例,在1行里输出全省畅通须要的最低成本。若统计数据不足以保证畅通,则输出“?”。
Sample Input
3 3
1 2 1
1 3 2
2 3 4
1 3
2 3 2
0 100
Sample Output
3
?

这是一道带权值的并查集,由于是中文题, 题意也就不用多说了。。

所以我是用结构体写的。。。


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<sstream>
#include<cmath> using namespace std; #define f1(i, n) for(int i=0; i<n; i++)
#define f2(i, n) for(int i=1; i<=n; i++)
#define f3(i, n) for(int i=n; i>=1; i--)
#define f4(i, n) for(int i=1; i<n; i++)
#define M 10050 int f[M];
int r[M];
int ans;
int t;
int n, m;
int coun; struct node
{
int x;
int y;
int cost; //花费
}q[M]; int cmp(node x1, node y1)
{
return x1.cost < y1.cost;
} int find(int x) //并查集的find
{
return f[x] == x ? x:f[x] = find( f[x] );
} void Kruskal()
{
sort(q, q+n, cmp);
f2(i, n)
{
int xx = find(q[i].x);
int yy = find(q[i].y);
if( xx!=yy ) //当不是统一集合时。。
{
ans+=q[i].cost;
f[yy] = xx;
coun --; //连起来一条路
}
}
} int main()
{
while(scanf("%d%d", &n, &m) &&n)
{
ans = 0;
t = 0;
coun = m;
f2(i, m) f[i] = i; //初始化
f2(i, n)
scanf("%d%d%d", &q[i].x, &q[i].y, &q[i].cost);
Kruskal();
if(coun==1)
printf("%d\n", ans);
else
printf("?\n");
} return 0;
}