徐州网络赛H-Ryuji doesn't want to study【线段树】

时间:2022-12-17 07:52:15

Ryuji is not a good student, and he doesn't want to study. But there are n books he should learn, each book has its knowledge a[i]a[i].

Unfortunately, the longer he learns, the fewer he gets.

That means, if he reads books from ll to rr, he will get a[l] \times L + a[l+1] \times (L-1) + \cdots + a[r-1] \times 2 + a[r]a[l]×L+a[l+1]×(L−1)+⋯+a[r−1]×2+a[r](LL is the length of [ ll, rr ] that equals to r - l + 1r−l+1).

Now Ryuji has qq questions, you should answer him:

11. If the question type is 11, you should answer how much knowledge he will get after he reads books [ ll, rr ].

22. If the question type is 22, Ryuji will change the ith book's knowledge to a new value.

Input

First line contains two integers nn and qq (nn, q \le 100000q≤100000).

The next line contains n integers represent a[i]( a[i] \le 1e9)a[i](a[i]≤1e9) .

Then in next qq line each line contains three integers aa, bb, cc, if a = 1a=1, it means question type is 11, and bb, cc represents [ ll , rr ]. if a = 2a=2 , it means question type is 22 , and bb, cc means Ryuji changes the bth book' knowledge to cc

Output

For each question, output one line with one integer represent the answer.

样例输入复制

5 3
1 2 3 4 5
1 1 3
2 5 0
1 4 5

样例输出复制

10
8

题目来源

ACM-ICPC 2018 徐州赛区网络预赛

题意:两种操作 一种是更新某节点

一种是查询l-r的一个值 这个值的计算公式是:徐州网络赛H-Ryuji doesn't want to study【线段树】

思路:

看上去就应该是一个线段树 区间查询单点更新

但是对于查询的处理没有那么简单

可以采用前缀和的思想 因为这个公式中的系数是递减的

那么我们在线段树中维护两个值 一个是本身的值 一个是(n-i+1)倍的值

那么我们查询的时候只需要查到倍数之和 减去 本身之和的(n-r)倍就可以了

WA了一会 因为没用long long

还是要注意啊这些细节 虽然单个没有超int 但是相加就会超的


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<vector>
#include<set>
//#include<bits/stdc++.h>
#define inf 0x7f7f7f7f7f7f7f7f
using namespace std;
typedef long long LL; const int maxn = 1e5 + 10;
LL tree[maxn << 2], treetime[maxn << 2], a[maxn];
int n, q; void pushup(int rt)
{
tree[rt] = tree[rt << 1] + tree[rt << 1 | 1];
treetime[rt] = treetime[rt << 1] + treetime[rt << 1 | 1];
} void build(int rt, int l, int r)
{
if (l == r) {
tree[rt] = a[l];
treetime[rt] = a[l] * (n - l + 1);
return;
}
int m = (l + r) / 2;
build(rt << 1, l, m);
build(rt << 1 | 1, m + 1, r);
pushup(rt);
} void update(int x, LL val, int l, int r, int rt)
{
if (l == r) {
tree[rt] = val;
treetime[rt] = val * (n - l + 1);
return;
}
int m = (l + r) / 2;
if (x <= m) {
update(x, val, l, m, rt << 1);
}
else {
update(x, val, m + 1, r, rt << 1 | 1);
}
pushup(rt);
} LL query(int L, int R, int l, int r, int rt)
{
if (L <= l && R >= r) {
return tree[rt];
}
int m = (l + r) / 2;
LL ans = 0;
if (L <= m) {
ans += query(L, R, l, m, rt << 1);
}
if (R > m) {
ans += query(L, R, m + 1, r, rt << 1 | 1);
}
pushup(rt);
return ans;
} LL querytime(int L, int R, int l, int r, int rt)
{
if (L <= l && R >= r) {
return treetime[rt];
}
int m = (l + r) / 2;
LL ans = 0;
if (L <= m) {
ans += querytime(L, R, l, m, rt << 1);
}
if (R > m) {
ans += querytime(L, R, m + 1, r, rt << 1 | 1);
}
return ans;
} void init()
{
memset(tree, 0, sizeof(tree));
memset(treetime, 0, sizeof(treetime));
} int main()
{
while (scanf("%d%d", &n, &q) != EOF) {
if(n == 0){
while(q--){
int op, l, r;
scanf("%d%d%d", &op, &l, &r);
printf("0\n");
}
continue;
}
init();
for (int i = 1; i <= n; i++) {
scanf("%lld", &a[i]);
}
build(1, 1, n); for (int i = 0; i < q; i++) {
int op, l, r;
scanf("%d%d%d", &op, &l, &r);
if (op == 1) {
LL ans = querytime(l, r, 1, n, 1) - (n - r) * query(l, r, 1, n, 1);
printf("%lld\n", ans);
}
else {
update(l, r, 1, n, 1);
}
}
}
return 0;
}

徐州网络赛H-Ryuji doesn't want to study【线段树】的更多相关文章

  1. 2018icpc徐州网络赛-H Ryuji doesn&&num;39&semi;t want to study&lpar;线段树&rpar;

    题意: 有n个数的一个数组a,有两个操作: 1 l r:查询区间[l,r]内$a[l]*(r-l+1)+a[l+1]*(r-l)+a[l+2]*(r-l-1)+\cdots+a[r-1]*2+a[r] ...

  2. 2018徐州网络赛H&period; Ryuji doesn&&num;39&semi;t want to study

    题目链接: https://nanti.jisuanke.com/t/31458 题解: 建立两个树状数组,第一个是,a[1]*n+a[2]*(n-1)....+a[n]*1;第二个是正常的a[1], ...

  3. ACM-ICPC 2018 徐州赛区网络预赛H Ryuji doesn&&num;39&semi;t want to study(树状数组)题解

    题意:给你数组a,有两个操作 1 l r,计算l到r的答案:a[l]×L+a[l+1]×(L−1)+⋯+a[r−1]×2+a[r] (L is the length of [ l, r ] that ...

  4. ACM-ICPC 2018 徐州赛区网络预赛 H&period; Ryuji doesn&&num;39&semi;t want to study(树状数组)

    Output For each question, output one line with one integer represent the answer. 样例输入 5 3 1 2 3 4 5 ...

  5. 计蒜客 31460 - Ryuji doesn&&num;39&semi;t want to study - &lbrack;线段树&rsqb;&lbrack;2018ICPC徐州网络预赛H题&rsqb;

    题目链接:https://nanti.jisuanke.com/t/31460 Ryuji is not a good student, and he doesn't want to study. B ...

  6. ACM-ICPC 2018 徐州赛区网络预赛 H&period; Ryuji doesn&&num;39&semi;t want to study (线段树)

    Ryuji is not a good student, and he doesn't want to study. But there are n books he should learn, ea ...

  7. 南昌网络赛 I&period; Max answer (单调栈 &plus; 线段树)

    https://nanti.jisuanke.com/t/38228 题意给你一个序列,对于每个连续子区间,有一个价值,等与这个区间和×区间最小值,求所有子区间的最大价值是多少. 分析:我们先用单调栈 ...

  8. ACM-ICPC 2018徐州网络赛-H题 Ryuji doesn&&num;39&semi;t want to study

    死于update的一个long long写成int了 真的不想写过程了 ******** 树状数组,一个平的一个斜着的,怎么斜都行 题库链接:https://nanti.jisuanke.com/t/ ...

  9. ACM-ICPC 2018 徐州赛区网络预赛 H&period; Ryuji doesn&&num;39&semi;t want to study

    262144K   Ryuji is not a good student, and he doesn't want to study. But there are n books he should ...

  10. ACM-ICPC 2018 徐州赛区网络预赛 H Ryuji doesn&&num;39&semi;t want to study &lpar;树状数组差分&rpar;

    https://nanti.jisuanke.com/t/31460 题意 两个操作.1:查询区间[l,r]的和,设长度为L=r-l+1, sum=a[l]*L+a[l+1]*(L-1)+...+a[ ...

随机推荐

  1. C语言(2)

    C语言(2)---变量 基本格式: 变量类型  变量名1[,变量名2,变量名3,...变量名n]: 注意: 1.在C语言中如果申请一个变量,里面存放小数,则用float表示,且在输出时需要注意prin ...

  2. Java GC系列(1):Java垃圾回收简介

    本文由 ImportNew - 好好先生 翻译自 javapapers. Java的内存分配与回收全部由JVM垃圾回收进程自动完成.与C语言不同,Java开发者不需要自己编写代码实现垃圾回收.这是Ja ...

  3. Android里viewpager切换页面存在页面不相邻的页面被销毁的问题

    我之前一直因为viewpager+fragment时,所有页面的状态都会被自动保存 这次自己做了一个添加了5跟fragment的viewpager 测试时发现当从第一个切换到第四个页面时,再回到第一个 ...

  4. iOS断点及打印日志

    首先,最简单的断点就是在Xcode项目文件中任意一行行号那点一下,就是加了一个断点 再次点击会变成浅蓝色,表示disable掉了 disable掉的断点不会起作用,但会在左上角蓝色的标签那留下记录,这 ...

  5. java android面试题分析总结

    本文参考多处,一并感谢! http://www.blogjava.net/fanyingjie/archive/2007/06/27/126467.aspx http://baike.baidu.co ...

  6. ACdream 1135&lpar;MST-最小生成树边上2个值,维护第一个最小的前提下让还有一个最小&rpar;

    F - MST Time Limit: 2000/1000MS (Java/Others) Memory Limit: 128000/64000KB (Java/Others) SubmitStatu ...

  7. Angular React 和 Vue的比较

    Angular(1&2),React,Vue对比 一 数据流 数据绑定 Angular 使用双向绑定即:界面的操作能实时反映到数据,数据的变更能实时展现到界面. 实现原理: $scope变量中 ...

  8. CentOS安装VirtualBox增强工具

    安装过程中出现错误: Bulding the VirtualBox Guest Additions Kernel modules failedYour system does not seem to  ...

  9. zabbix&lowbar;sender用法实例

    环境centos6.8 zabbix版本3.2.4 需求: 要远程监控一台服务器A,但只能通过远程服务器连接本地服务器B,但B不能主动连A(因为A没有固定公网ip) 使用了zabbix_agent的a ...

  10. 使用locate 的正则查询 查找所有main&period;c

    locate支持正则查询的功能, 只需输入locate -r 正则表达式     即可. 现在我想查找所有main.c怎么做? 打开终端,输入shell: locate -r main.c$ PS:' ...