[ACM_数学] 大菲波数 (hdu oj 1715 ,java 大数)

时间:2023-12-27 00:01:55

大菲波数

Problem Description
Fibonacci数列,定义如下:
f(1)=f(2)=1
f(n)=f(n-1)+f(n-2) n>=3。
计算第n项Fibonacci数值。
Input
输入第一行为一个整数N,接下来N行为整数Pi(1<=Pi<=1000)。
Output
输出为N行,每行为对应的f(Pi)。
Sample Input
5
1
2
3
4
5
Sample Output
1
1
2
3
5
 import java.math.BigInteger;
import java.util.Scanner; public class A{
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
BigInteger fib[] = new BigInteger[100];
fib[1] = new BigInteger("1");
fib[2] = new BigInteger("1");
for (int i = 3; i <= 1000; ++i) {
fib[i] = fib[i - 1].add(fib[i - 2]);
}
while (scanner.hasNextInt()) {
int t = scanner.nextInt();
while (t > 0) {
int i = scanner.nextInt();
System.out.println(fib[i]);
t--;
}
}
}
}