F: 火柴棒等式

时间:2022-11-05 15:54:46

Problem F: 火柴棒等式

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 18  Solved: 13
[ Submit][ Status][ Web Board]

Description

给你n根火柴棍,你可以拼出多少个形如“A+B=C”的等式?等式中的A、B、C是用火柴棍拼出的整数(若该数非零,则最高位不能是0)。用火柴棍拼数字0-9的拼法如图所示:

F: 火柴棒等式

注意:

1. 加号与等号各自需要两根火柴棍

2. 如果A≠B,则A+B=C与B+A=C视为不同的等式(A、B、C>=0)

3. n根火柴棍必须全部用上

Input

输入文件matches.in共一行,又一个整数n(n<=24)。

Output

输出文件matches.out共一行,表示能拼成的不同等式的数目。

Sample Input

14
18

Sample Output

29

HINT

【输入输出样例1解释】


2个等式为0+1=1和1+0=1。


【输入输出样例2解释】


9个等式为:


0+4=4


0+11=11


1+10=11


2+2=4


2+7=9


4+0=4


7+2=9


10+1=11


11+0=11


【题解】:

我就是0的情况没注意到,进while里面的时候不能进去,样例一直没过,特殊判断就行了


【代码】:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <set>
#include <map>
#include <vector>
using namespace  std;
int sum[]={6,2,5,5,4,5,6,3,7,6};
int cnt;
int xx(int n)
{
    int a;
    if(n==0)
        cnt+=sum[n];
    else{
        while(n)
        {
            a=n%10;
            cnt+=sum[a];
            n/=10;
        }
    }
}
int main()
{
    int n,nn;
    while(~scanf("%d",&n))
    {
        cnt=0;nn=0;
        for(int i=0;i<1000;i++)
            for(int j=0;j<1000;j++){
                xx(i);xx(j);xx(i+j);
                if(cnt+4==n){
                    nn++;
                    //printf("%d**%d\n",i,j);
                }
                 cnt=0;
            }
        printf("%d\n",nn);
    }
    return 0;
}