A:分段函数-poj

时间:2022-06-28 16:49:45

A:分段函数

总时间限制: 
1000ms

内存限制: 
65536kB
描述

编写程序,计算下列分段函数y=f(x)的值。

y=-x+2.5; 0 <= x < 5

y=2-1.5(x-3)(x-3); 5 <= x < 10

y=x/2-1.5; 10 <= x < 20

输入
一个浮点数N,0 <= N < 20
输出
输出N对应的分段函数值:f(N)。结果保留到小数点后三位。
样例输入
1.0
样例输出
1.500
代码:
/*
编写程序,计算下列分段函数y=f(x)的值。 y=-x+2.5; 0 <= x < 5
y=2-1.5(x-3)(x-3); 5 <= x < 10
y=x/2-1.5; 10 <= x < 20
*/
#include<stdio.h>
#include<iostream>
using namespace std;
#include<string.h>
int main()
{
float x,y;
scanf("%f",&x);
if(x>=&&x<)
{
y=-x+2.5;
//cout<<y<<endl;
}
else
if(x>=&&x<)
{
y=+1.5*(x-)*(x-);
}
else
if(x>=&&x<)
{
y=x/-1.5;
}
printf("%.3f\n",y);
return ;
}