hdu1052 Tian Ji -- The Horse Racing 馋

时间:2022-09-06 13:26:04

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:

pid=1052">http://acm.hdu.edu.cn/showproblem.php?pid=1052

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17346    Accepted Submission(s): 5043

Problem Description
Here is a famous story in Chinese history.



"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."



"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from
the loser."



"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."



"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."



"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you
think of Tian Ji, the high ranked official in China?

"



hdu1052 Tian Ji -- The Horse Racing 馋



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find
the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...



However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too
advanced tool to deal with the problem.



In this problem, you are asked to write a program to solve this special case of matching problem.

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses.
Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 
Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
Sample Input
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0
 
Sample Output
200
0
0
 
Source
 
Recommend
JGShining   |   We have carefully selected several similar problems for you:  

pid=1051">1051

 1257 

pid=1053">1053

 1789 2187 

/*

每次取田忌的最快的马与齐王最快的马比較,有三种情况。

一、田忌最快的马比齐王最快的快,那么直接用田忌最快的马去赢齐王最快的马。

二、田忌最快的马比齐王最快的慢,那么用田忌最慢的马去输齐王最快的马。

三、田忌最快的马与齐王最快的马速度一样。

先用田忌最慢的马与齐王最慢的马比較。

若田忌比齐王快,直接赢掉齐王最慢的马。

否则田忌最慢的马再去与齐王最快的马比。

     假设最快最慢的马都一样。用田忌最慢的马和齐王最快的马比。

*/

代码例如以下:
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <cstdlib>
#include <climits>
#include <ctype.h>
#include <queue>
#include <stack>
#include <vector>
#include <deque>
#include <set>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;
#define PI acos(-1.0)
#define INF 0x3fffffff
int main()
{
int n,i,j;
int a[1047],b[1047];
while(~scanf("%d",&n) && n)
{
for(i = 1 ; i <= n ; i++)
{
scanf("%d",&a[i]);
}
sort(a+1,a+n+1);
for(i = 1 ; i <= n ; i++)
{
scanf("%d",&b[i]);
}
sort(b+1,b+n+1);
int sum = 0;
int ka1,kb1;//分别计算田忌和齐王速度慢的马还未使用的当前序号边界
int ka2,kb2;//分别计算田忌和齐王速度快的马还未使用的当前序号边界
ka1 = kb1 = 1;
ka2 = kb2 = n;
for(i = n ; i >= 1; i--)
{
if(a[ka2] > b[kb2])//假设田忌最快的马比齐王最快的马快直接吃掉
{
sum+=200;
ka2--,kb2--;
}
else if(a[ka2] == b[kb2])//假设两方最快的马速度同样
{
if(a[ka1] > b[kb1])//假设田忌最慢的马比齐王最慢的快,直接吃掉
{
sum+=200;
ka1++,kb1++;
}
else if(a[ka1] <= b[kb1])//假设田忌最慢的马和齐王最慢的马速度同样或比齐王慢
{
if(a[ka1] < b[kb2])//假设田忌最慢的马比齐王最快的马慢。用最慢的去输齐王最快的
{//PS:可能会有读者吐槽,最慢的马当让比最快的慢。事实上不然。比方题目的第二个案例
sum-=200;
ka1++;
kb2--;
}
else if(a[ka1] == b[kb2])//两方的马全是一样的速度的情况,那么直接能够忽略掉钱的变化
{
ka1++,kb2--;
}
}
}
else if(a[ka2] < b[kb2])//假设田忌最快的马比齐王最快的马慢。用田忌最慢的马去输齐王最快的马
{
sum-=200;
ka1++;
kb2--;
}
}
printf("%d\n",sum);
}
return 0;
}

版权声明:本文博主原创文章,博客,未经同意不得转载。

hdu1052 Tian Ji -- The Horse Racing 馋的更多相关文章

  1. 【贪心】&lbrack;hdu1052&rsqb;Tian Ji -- The Horse Racing&lpar;田忌赛马&rpar;&lbrack;c&plus;&plus;&rsqb;

    Tian Ji -- The Horse Racing Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java ...

  2. HDU-1052 Tian Ji -- The Horse Racing 贪心 考虑特殊位置(首尾元素)的讨论

    题目链接:https://cn.vjudge.net/problem/HDU-1052 题意 田忌赛马问题扩展版 给n匹马,马的能力可以相同 问得分最大多少 思路 贪心做得还是太少,一开始一点思虑都没 ...

  3. &lbrack;HDU1052&rsqb;Tian Ji -- The Horse Racing&lpar;田忌赛马&rpar;

    题目大意:田忌赛马问题,给出田忌和齐威王的马的数量$n$和每匹马的速度$v$,求田忌最多赢齐威王多少钱(赢一局得200,输一局扣200,平局不得不扣). 思路:贪心. 1.若田忌最慢的马可以战胜齐王最 ...

  4. Hdu 1052 Tian Ji -- The Horse Racing

    Tian Ji -- The Horse Racing Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (J ...

  5. Tian Ji -- The Horse Racing

    Tian Ji -- The Horse Racing Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Jav ...

  6. UVA 1344 Tian Ji -- The Horse Racing

    Tian Ji -- The Horse Racing Here is a famous story in Chinese history. That was about 2300 years ago ...

  7. hdoj 1052 Tian Ji -- The Horse Racing【田忌赛马】 【贪心】

    思路:先按从小到大排序, 然后从最快的開始比(如果i, j 是最慢的一端, flag1, flag2是最快的一端 ),田的最快的大于king的 则比較,如果等于然后推断,有三种情况: 一:大于则比較, ...

  8. 杭州电 1052 Tian Ji -- The Horse Racing(贪婪)

    http://acm.hdu.edu.cn/showproblem.php? pid=1052 Tian Ji -- The Horse Racing Time Limit: 2000/1000 MS ...

  9. 【OpenJ&lowbar;Bailian - 2287】Tian Ji -- The Horse Racing (贪心)

    Tian Ji -- The Horse Racing 田忌赛马,还是English,要不是看题目,我都被原题整懵了,直接上Chinese吧 Descriptions: 田忌和齐王赛马,他们各有n匹马 ...

随机推荐

  1. 一段良好的程序永远不应该发生panic异常

    panic来自被调函数的信号,表示发生了某个已知的bug.一段良好的程序永远不应该发生panic异常 对于大部分程序而言,永远无法保证能够成功运行,因为错误原因往往超出程序员的控制范围.任何进行io操 ...

  2. Java反射机制(Reflection)

    Java反射机制(Reflection) 一.反射机制是什么 Java反射机制是程序在运行过程中,对于任意一个类都能够知道这个类的所有属性和方法;对于任意一个对象都能够调用它的任意一个方法和属性,这种 ...

  3. linux 下 文件权限和文件主

    文件与文件夹的权限和所有者 1.chmod -R 755 file 777 含义与来源: 777含义:分别为:所有者.同组用户.其他用户 7的来源:文件有三种操作模式:读4.写2.执行1,分别值为42 ...

  4. Mybatis传多个参数&lpar;三种解决方案&rpar;

    第一种方案 DAO层的函数方法 Public User selectUser(String name,String area); 对应的Mapper.xml <select id="s ...

  5. TopCoder 649 div1 &amp&semi; div2

    最近一场TC,做得是在是烂,不过最后challenge阶段用一个随机数据cha了一个明显错误的代码,最后免于暴跌rating,还涨了一点.TC题目质量还是很高的,非常锻炼思维,拓展做题的视野,老老实实 ...

  6. Jmeter&lowbar;24个常用函数

    JMeter提供了很多函数,如果能够熟练使用,可以为脚本带来很多方便. JMeter函数是一种特殊值,可用于除测试计划外的任何组件. 函数调用的格式如下所示:${__functionName(var1 ...

  7. ApiUser

    using System; using System.Runtime.InteropServices; using System.Text; using HANDLE = System.IntPtr; ...

  8. 文本分类-TensorRT优化结果对比图

    做的文本二分类,使用tensorRT进行图优化和加速,输出预测概率结果对比如下: 从结果对比来看,概率值有微小的变化,但不影响最终的分类

  9. EF 1

    安装框架: 在NuGet中安装ef框架,命令:Install-package EntityFramework 数据迁移: 在程序包管理器控制台,执行语句. 初始化: 1.Enable-Migratio ...

  10. 《PHP&comma; MySQL&comma; Javascript和CSS》读书随手记----MySQL篇

    一 基础 要求结尾分号 如果在命令输入期间想要终止其运行,不要Ctrl-C. 要输入\c,并按回车键. sql命令和关键字不区分大小写. 表名在windows中不区分大小写,但是在linux和os x ...