PAT 1065. A+B and C (64bit) (20)

时间:2022-03-30 19:49:48

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
 
参考代码:
 
#include<stdio.h>
#include <climits>

int main() {
	//freopen("in.txt","r",stdin);
	
	int n, i;
	long long a, b, c;// vc不支持long long,只支持__int64
	scanf("%d",&n);
	for(i=1; i<=n; i++) {
		scanf("%lld %lld %lld",&a,&b,&c);
		//a+b只有赋值后才可以检测是否溢出
		long long tmp = a +b;
		if(a>0 && b>0 && tmp<=0) {//a>0 && b>0 && a>LLONG_MAX-b
			printf("%s%d%s\n","Case #",i,": true");
			continue;
		}
		if (a<0 && b<0 && tmp>=0) {//a<0 && b<0 && a<LLONG_MIN-b
			printf("%s%d%s\n","Case #",i,": false");
			continue;
		}
		if(a+b > c)
			printf("%s%d%s\n","Case #",i,": true");
		else
			printf("%s%d%s\n","Case #",i,": false");
	}

	return 0;
}