POJ_3068_Shortest_pair_of_paths_(最小费用流)

时间:2023-11-14 15:19:56

描述


http://poj.org/problem?id=3068

危险品:N个仓库由M条有向边连接,每条边都有一定费用。将两种危险品从0运到N-1,除了起点和终点外,危险品不能放在一起,也不能走相同的路径。求最小费用.

(好吧直接抄来的0.0)

"Shortest" pair of paths
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1220   Accepted: 493

Description

A chemical company has an unusual shortest path problem.

There are N depots (vertices) where chemicals can be stored. There
are M individual shipping methods (edges) connecting pairs of depots.
Each individual shipping method has a cost. In the usual problem, the
company would need to find a way to route a single shipment from the
first depot (0) to the last (N - 1). That's easy. The problem they have
seems harder. They have to ship two chemicals from the first depot (0)
to the last (N - 1). The chemicals are dangerous and cannot safely be
placed together. The regulations say the company cannot use the same
shipping method for both chemicals. Further, the company cannot place
the two chemicals in same depot (for any length of time) without special
storage handling --- available only at the first and last depots. To
begin, they need to know if it's possible to ship both chemicals under
these constraints. Next, they need to find the least cost of shipping
both chemicals from first depot to the last depot. In brief, they need
two completely separate paths (from the first depot to the last) where
the overall cost of both is minimal.

Your program must simply determine the minimum cost or, if it's not
possible, conclusively state that the shipment cannot be made.

Input

The
input will consist of multiple cases. The first line of each input will
contain N and M where N is the number of depots and M is the number of
individual shipping methods. You may assume that N is less than 64 and
that M is less than 10000. The next M lines will contain three values,
i, j, and v. Each line corresponds a single, unique shipping method. The
values i and j are the indices of two depots, and v is the cost of
getting from i to j. Note that these shipping methods are directed. If
something can be shipped from i to j with cost 10, that says nothing
about shipping from j to i. Also, there may be more than one way to ship
between any pair of depots, and that may be important here.

A line containing two zeroes signals the end of data and should not be processed.

Output

follow the output format of sample output.

Sample Input

2 1
0 1 20
2 3
0 1 20
0 1 20
1 0 10
4 6
0 1 22
1 3 11
0 2 14
2 3 26
0 3 43
0 3 58
0 0

Sample Output

Instance #1: Not possible
Instance #2: 40
Instance #3: 73

Source

分析


每个边的容量都是1,增加一个源点与汇点,与他们相连的边容量是2,费用是0.然后跑最小费用流即可.

注意:

1.加爆了什么的...好吧只有我才会犯这种智障错(撞墙).

ps.人生第一道最小费用流的题.还有两个月就NOI了,感觉这节奏不死真难.

 #include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
#define rep(i,n) for(int i=0;i<(n);i++)
#define for1(i,a,n) for(int i=(a);i<=(n);i++)
#define read(a) a=getnum()
#define CC(i,a) memset(i,a,sizeof(i))
using namespace std; const int maxn=+,INF=<<;
int n,m;
bool vis[maxn];
int dis[maxn],prevv[maxn],preve[maxn];
struct edge
{
int to,cap,cost,rev;
edge(){}
edge(int a,int b,int c,int d):to(a),cap(b),cost(c),rev(d) {}
};
vector <edge> g[maxn]; inline int getnum()
{
int r=,k=; char c;
for(c=getchar();c<''||c>'';c=getchar()) if(c=='-') k=-;
for(;c>=''&&c<='';c=getchar()) r=r*+c-'';
return k*r;
} void add_edge(int from,int to,int cap,int cost)
{
g[from].push_back(edge(to,cap,cost,g[to].size()));
g[to].push_back(edge(from,,-cost,g[from].size()-));
} void Spfa(int s)
{
for1(i,,n+) dis[i]=INF;
dis[s]=;
CC(vis,);
queue <int> q;
q.push(s);
vis[s]=true;
while(!q.empty())
{
int t=q.front(); q.pop();
vis[t]=false;
rep(i,g[t].size())
{
edge e=g[t][i];
if(e.cap>&&dis[e.to]-e.cost>dis[t])
{
dis[e.to]=dis[t]+e.cost;
prevv[e.to]=t;
preve[e.to]=i;
if(!vis[e.to])
{
vis[e.to]=true;
q.push(e.to);
}
}
}
}
} int min_cost_flow(int s,int t,int f)
{
int res=;
while(f>)
{
Spfa(s);
if(dis[t]==INF) return -;
int d=f;
for(int v=t;v!=s;v=prevv[v])
{
d=min(d,g[prevv[v]][preve[v]].cap);
}
f-=d;
res+=d*dis[t];
for(int v=t;v!=s;v=prevv[v])
{
edge &e=g[prevv[v]][preve[v]];
e.cap-=d;
g[v][e.rev].cap+=d;
}
}
return res;
} int main()
{
#ifndef ONLINE_JUDGE
freopen("short.in","r",stdin);
freopen("short.out","w",stdout);
#endif
int cnt=;
while(scanf("%d%d",&n,&m)==&&(n!=||m!=))
{
for1(i,,m)
{
int from,to,cost;
read(from); read(to); read(cost);
from++; to++;
add_edge(from,to,,cost);
}
add_edge(,,,);
add_edge(n,n+,,);
printf("Instance #%d: ",++cnt);
int ans=min_cost_flow(,n+,);
if(ans==-)
{
printf("Not possible\n");
}
else
{
printf("%d\n",ans);
}
for1(i,,n+) g[i].clear();
}
#ifndef ONLINE_JUDGE
fclose(stdin);
fclose(stdout);
system("short.out");
#endif
return ;
}