Souvenir
Accepts: 901
Submissions: 2743
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 262144/262144 K (Java/Others)
Problem Description
Today is the 1st anniversary of BestCoder. Soda, the contest manager, wants to buy a souvenir for each contestant. You can buy the souvenir one by one or set by set in the shop. The price for a souvenir is
p
yuan and the price for a set of souvenirs if
q
yuan. There's m
souvenirs in one set.There's
n
contestants in the contest today. Soda wants to know the minimum cost needed to buy a souvenir for each contestant.
p
yuan and the price for a set of souvenirs if
q
yuan. There's m
souvenirs in one set.There's
n
contestants in the contest today. Soda wants to know the minimum cost needed to buy a souvenir for each contestant.
Input
There are multiple test cases. The first line of input contains an integer
T
(1≤T≤105),
indicating the number of test cases. For each test case:There's a line containing 4 integers
n,m,p,q
(1≤n,m,p,q≤104).
T
(1≤T≤105),
indicating the number of test cases. For each test case:There's a line containing 4 integers
n,m,p,q
(1≤n,m,p,q≤104).
Output
For each test case, output the minimum cost needed.
Sample Input
2
1 2 2 1
1 2 3 4
Sample Output
1
3HintFor the first case, Soda can use 1 yuan to buy a set of 2 souvenirs. For the second case, Soda can use 3 yuan to buy a souvenir.#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h> using namespace std; int main()
{
int T;
scanf("%d",&T);
while(T--)
{
__int64 sum = 0;
int n,m,p,q;
scanf("%d%d%d%d",&n,&m,&p,&q);
if(p*m<=q)
{
printf("%d\n",p*n);
}
else
{
sum = (n/m)*q;
n = n%m;
if(n*p<q)
{
printf("%I64d\n",sum+n*p);
}
else
{
printf("%I64d\n",sum+q);
}
}
}
return 0;
}