【考虑周全+数学变形】【11月赛】Is it a fantastic matrix?

时间:2022-08-26 09:57:16

Is it a fantastic matrix?

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 2

Problem Description

Given an n*m matrix, you are asked to judge if it's fantastic. The rule is: firstly, choose min (n, m) numbers from it, meanwhile you should make sure any two numbers you select will not at the same row or same column. Of course, you may have many different
ways to get the numbers. For every way, if the sum of all selected numbers is always same, you may say the matrix is fantastic.

Input

The first line contains an integer T, stands for the number of test cases. (1<=T<=100)

T cases follow, for every case:

The first line contains two integers n and m. (1 <= n, m <= 50)

Then n lines follows, each line contains m integers. Every number in the matrix will between -100000 and 100000.

Output

For every case, if it is a fantastic matrix, output “YES” in one line, otherwise output “NO”.

Sample Input

3
2 2
1 3
2 4
2 3
1 1 1
1 1 1
2 1
2
3

Sample Output

YES
YES
NO

Source

hujie 测试专用(2)

这个题当初就思考了很久 可惜还是没有考虑 周全

当n<m的时候 每一行都必须相同
1 1 1 1
2 2 2 2
3 3 3 3
如果不相同显然反例可证明
n>m 时候同理


当时只考虑了n==m的情况
得到了等式 a[k][jk]+a[t][jt]=a[k][jt]+a[t][jk]; (利用行列式的方式描述一个元素的位置 a[1][j1])

当k=1 ,jk=1 的时候  a[1][1]+a[t][jt]=a[1][jt]+a[t][1];
同时可以写出另外3个
a[k][jk]+a[1][1]=a[k][1]+a[1][jk]
a[1][jk]+a[t][1]=a[1][1]+a[t][jk]
a[k][1]+a[1][jt]=a[k][jt]+a[1][1]
累加起来即为 a[k][jk]+a[t][jt]=a[k][jt]+a[t][jk]

所以我们只需判断 a[x][y]+a[1][1]==a[x][1]+a[1][y]即可
代码如下:
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <ctime>
#include <algorithm>
#include <iostream>
#include <sstream>
#include <string>
#define oo 0x13131313
using namespace std;
int MAP[60][60];
int main()
{
int T;
cin>>T;
while(T--)
{
int OK=1;
int m,n;
cin>>n>>m;
if(n>m) //懒得写
if(n<m) //懒得写
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
scanf("%d",&MAP[i][j]);
if(n==1||m==1) { printf("NO\n");continue;}
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
if(MAP[i][j]+MAP[1][1]!=MAP[1][j]+MAP[i][1]) OK=0;
if(OK) cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}
}

【考虑周全+数学变形】【11月赛】Is it a fantastic matrix?的更多相关文章

  1. &lbrack;LOJ 6249&rsqb;「CodePlus 2017 11 月赛」汀博尔

    Description 有 n 棵树,初始时每棵树的高度为 H_i,第 i 棵树每月都会长高 A_i.现在有个木料长度总量为 S 的订单,客户要求每块木料的长度不能小于 L,而且木料必须是整棵树(即不 ...

  2. &lbrack;LOJ 6248&rsqb;「CodePlus 2017 11 月赛」晨跑

    Description “无体育,不清华”.“每天锻炼一小时,健康工作五十年,幸福生活一辈子” 在清华,体育运动绝对是同学们生活中不可或缺的一部分.为了响应学校的号召,模范好学生王队长决定坚持晨跑.不 ...

  3. &lbrack;CodePlus 2017 11月赛&amp&semi;洛谷P4058&rsqb;木材 题解(二分答案)

    [CodePlus 2017 11月赛&洛谷P4058]木材 Description 有 n棵树,初始时每棵树的高度为 Hi ,第 i棵树每月都会长高 Ai.现在有个木料长度总量为 S的订单, ...

  4. &lbrack;CodePlus 2017 11月赛&rsqb;晨跑 题解(辗转相除法求GCD)

    [CodePlus 2017 11月赛]晨跑 Description "无体育,不清华"."每天锻炼一小时,健康工作五十年,幸福生活一辈子".在清华,体育运动绝 ...

  5. &lbrack;BZOJ5109&rsqb;&lbrack;LOJ &num;6252&rsqb;&lbrack;P4061&rsqb;&lbrack;CodePlus 2017 11月赛&rsqb;大吉大利,今晚吃鸡!&lpar;最短路&plus;拓扑排序&plus;传递闭包&plus;map&plus;bitset&lpar;hash&plus;压位&rpar;&rpar;

    5109: [CodePlus 2017]大吉大利,晚上吃鸡! Time Limit: 30 Sec  Memory Limit: 1024 MBSubmit: 107  Solved: 57[Sub ...

  6. loj &num;6250&period; 「CodePlus 2017 11 月赛」找爸爸

    #6250. 「CodePlus 2017 11 月赛」找爸爸 题目描述 小 A 最近一直在找自己的爸爸,用什么办法呢,就是 DNA 比对. 小 A 有一套自己的 DNA 序列比较方法,其最终目标是最 ...

  7. FOJ 2013 11 月赛

    这套题目还是比较吊的,由于我的沙茶,还是很多没有做出来- -! C:逆序数 D:呵呵 A:妈蛋,自己精度没弄好,想到之前GCC的要加eps,就WA了几次后交Visual C++过了!C(n,m)p^m ...

  8. 「CodePlus 2017 11 月赛」Yazid 的新生舞会(树状数组&sol;线段树)

    学习了新姿势..(一直看不懂大爷的代码卡了好久T T 首先数字范围那么小可以考虑枚举众数来计算答案,设当前枚举到$x$,$s_i$为前$i$个数中$x$的出现次数,则满足$2*s_r-r > 2 ...

  9. 「CodePlus 2017 11 月赛」大吉大利,晚上吃鸡!(dij&plus;bitset)

    从S出发跑dij,从T出发跑dij,顺便最短路计数. 令$F(x)$为$S$到$T$最短路经过$x$的方案数,显然这个是可以用$S$到$x$的方案数乘$T$到$x$的方案数来得到. 然后第一个条件就变 ...

随机推荐

  1. ORA-14452的出现原因解析及解决方法

    在删除临时表时遇到了ORA-14452错误:ORA-14452: attempt to create , alert or drop an index on temporary table alrea ...

  2. Java语言程序设计&lpar;基础篇&rpar; 第三章 选择

    第三章 选择 3.8 计算身体质量指数 package com.chapter3; import java.util.Scanner; public class ComputeAndInterpret ...

  3. 安装RabbitMQ遇到的问题

    消息队列RabbitMQ在安装的时候出现了问题.. 我这里是参考的 .NET 环境中使用RabbitMQ 进行安装的..首先声明 这篇博文没有问题.. 但是在我安装的时候发现..ErLang环境装完 ...

  4. 【转载】javaAgent 参数

    -javaagent 这个JVM参数是JDK 5引进的. java -help的帮助里面写道: -javaagent:<jarpath>[=<options>] load Ja ...

  5. 3D数学基础:3D游戏动画中欧拉角与万向锁的理解

    首先来看一下什么是欧拉角(Euler angles)?构件在三维空间中的有限转动,可依次用三个相对转角表示,即进动角.章动角和自旋角,这三个转角统称为欧拉角.——引自百度百科莱昂哈德·欧拉用欧拉角来描 ...

  6. nc命令学习

    监测端口是否存在 nc -z 127.0.0.1 9100 扫描端口 nc -z -v 127.0.0.1 8000 9999 发送http nc www.baidu.com 80 GET / HTT ...

  7. openerp - asterisk connector(转载)

    原文:http://www.akretion.com/open-source-contributions/openerp-asterisk-voip-connector OpenERP - Aster ...

  8. ActionBar官方教程&lpar;5&rpar;ActionBar的分裂模式&lpar;底部tab样式&rpar;&comma;隐藏标题&comma;隐藏图标

    Using split action bar Split action bar provides a separate bar at the bottom of the screen to displ ...

  9. event&period;srcElement获得引发事件的控件(表单)

    <1> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://w ...

  10. ehcache memcache redis 三大缓存对比

    详见:http://blog.yemou.net/article/query/info/tytfjhfascvhzxcyt268 最近项目组有用到这三个缓存,去各自的官方看了下,觉得还真的各有千秋!今 ...