I - Matches Game(异或运算符的使用)

时间:2021-09-28 17:28:40

I - Matches Game

Description


Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input


The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output


For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output


No
Yes

思路:两个相同的数异或后将会等于0,可以运用这个性质解决这题。(经典的博弈论问题)

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
int n;
int a[22];
while(scanf("%d",&n)!=EOF)
{
int out=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
out^=a[i];
}
if(out==0) printf("No\n"); //判断是否都成对
else printf("Yes\n");
}
return 0;
}