HDU 1280 前m大的数(排序,字符串)

时间:2022-04-19 17:25:37
 

前m大的数

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19170    Accepted Submission(s): 6546

Problem Description
还记得Gardon给小希布置的那个作业么?(上次比赛的1005)其实小希已经找回了原来的那张数表,现在她想确认一下她的答案是否正确,但是整个的答案是很庞大的表,小希只想让你把答案中最大的M个数告诉她就可以了。
给定一个包含N(N<=3000)个正整数的序列,每个数不超过5000,对它们两两相加得到的N*(N-1)/2个和,求出其中前M大的数(M<=1000)并按从大到小的顺序排列。
Input
输入可能包含多组数据,其中每组数据包括两行:
第一行两个数N和M,
第二行N个数,表示该序列。
Output
对于输入的每组数据,输出M个数,表示结果。输出应当按照从大到小的顺序排列。
Sample Input
4 4
1 2 3 4
4 5
5 3 6 4
Sample Output
7 6 5 5
11 10 9 9 8
Author
Gardon
Source
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
bool cmp(int a,int b)
{ return a>b;
}
int a[3001];
int b[4500000];
int main ()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(b,0,sizeof(b));//
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
sort(a,a+n,cmp);// int t=0;
for(int i=0;i<n;i++)
{
for(int j=i+1;j<n;j++)
{
b[t]=a[i]+a[j];
t++;
}
} sort(b,b+(n*(n-1)/2),cmp);//
for(int i=0;i<m;i++)
{
printf("%d",b[i]);
if(i!=m-1)
printf(" ");
else
printf("\n");
} }
return 0;
}