Matrix
Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 21757 | Accepted: 8141 |
Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above.
Output
For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.
There is a blank line between every two continuous test cases.
Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output
1
0
0
1
题意是起始给出一个全为0的矩阵,然后不断地对其子矩阵操作,0变为1,1变为0。然后也不断查询某一个位置的值。
二维树状数组,之前一直理解错了,其实转换的那四块是对上面的部分,不是下面的部分。
代码:
#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;
#define MY_MAX 1100 int tree[MY_MAX*3][MY_MAX*3];
int n,t; int lowbit(int x)
{
return x&(-x);
} int get_num(int x,int y)
{
int sum=0,i,j;
for(i=x;i>0;i=i-lowbit(i))
{
for(j=y;j>0;j=j-lowbit(j))
{
sum += tree[i][j];
}
}
return sum;
} void cal(int x,int y)
{
int i,j;
for(i=x;i<=n;i=i+lowbit(i))
{
for(j=y;j<=n;j=j+lowbit(j))
{
tree[i][j]++;
}
}
} int main()
{
//freopen("i.txt","r",stdin);
//freopen("o.txt","w",stdout); int test,i,x1,y1,x2,y2,x,y;
char oper[10];
scanf("%d",&test); while(test--)
{
scanf("%d%d",&n,&t);
memset(tree,0,sizeof(tree));
for(i=1;i<=t;i++)
{
scanf("%s",oper);
if(oper[0]=='C')
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
cal(x2+1,y2+1);
cal(x1,y1);
cal(x1,y2+1);
cal(x2+1,y1);
}
else if(oper[0]=='Q')
{
scanf("%d%d",&x,&y);
printf("%d\n",get_num(x,y)%2);
}
}
printf("\n");
}
//system("pause");
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。