单臂路由+交换机远程登录
单臂路由解决了不同vlan之间的通信问题,同时也解决了交换机和路由器之间端口占用的问题,这个也是学习网络很基础很基础的了吧,同时我还做了个交换机远程登录的功能,并且是从不同的vlan也能登录,在路由器上做了三个子接口的封装,拓扑如果:
~思科网络基础~单臂路由~telnet交换机
pc1:192.168.1.10     vlan10    
pc2:192.168.2.10     vlan20
交换机管理vlan:192.168.3.10   vlan100

单臂路由实现pc1和pc2互通,并且pc1和pc2都能telnet交换机192.168.3.10
交换机:

switch(config)#vlan 2

switch(config-vlan)#name  *****

switch(config)#vlan 3

switch(config-vlan)#name  *****


switch(config)#interface f0/2

switch(config-if)#no sh

switch(config-if)#switchport access vlan 2

switch(config-if)#exit

switch(config)#interface f0/3

switch(config-if)#no sh

switch(config-if)#switchport access vlan 3

switch(config-if)#exit


switch(config)#inteface f0/1

switch(config-if)#switchport mode trunk
switch(config)#ip default-gateway 192.168.3.1

路由器:

router(config)#interface f0/0

router(config-if)#no sh

router(config-if)#exit

router(config)#interface f0/0.1

router(config-subif)#encapsulation dot1q 2                            封装vlan2

router(config-if)#ip add 192.168.1.1 255.255.255.0

router(config-if)#exit

router(config)#interface f0/0.2

router(config-subif)#encapsulation dot1q 3                            封装vlan3

router(config-if)#ip add 192.168.2.1 255.255.255.0

router(config-if)#exit

router(config)#interface f0/0.3

router(config-subif)#encapsulation dot1q 100                        封装vlan100

router(config-if)#ip add 192.168.3.1 255.255.255.0

router(config-if)#exit

以上的单臂路由就完成了,检测下:
~思科网络基础~单臂路由~telnet交换机

接下来看看telnet:

switch(config)#interface vlan 1

switch(config-if)#ip address 192.168.1.1 255.255.255.0

switch(config-if)#no shutdown

switch(config-if)exit

switch(config)#line vty 0 4

switch(config-line)#password ********              //配置telnet密码

switch(config-line)#login

同样,测试一下:
~思科网络基础~单臂路由~telnet交换机
发现有提示,没有设置password,知道了吧,telnet是要设置enable password(或者secret)的
switch(config)#enable secret cisco      //配置进去特权模式的密码,不然只能在用户模式
再试试:
~思科网络基础~单臂路由~telnet交换机
好了,至此,很基础的单臂路由和远程telnet就是这样^