1108 Finding Average (20 分)

时间:2023-03-09 20:36:19
1108 Finding Average (20 分)
1108 Finding Average (20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

分析:字符串水题

 /**
 * Copyright(c)
 * All rights reserved.
 * Author : Mered1th
 * Date : 2019-02-26-19.44.56
 * Description : A1108
 */
 #include<cstdio>
 #include<cstring>
 #include<iostream>
 #include<cmath>
 #include<algorithm>
 #include<string>
 #include<unordered_set>
 #include<map>
 #include<vector>
 #include<set>
 using namespace std;

 int main(){
 #ifdef ONLINE_JUDGE
 #else
     freopen("1.txt", "r", stdin);
 #endif
     ;
     cin>>n;
     string str;
     double ans=0.0;
     ;i<n;i++){
         cin>>str;
         int len=str.length(),j;
         bool flag=false;
         ;j<len;j++){
             if(str[j]=='-') continue;
             if(str[j]=='.'&&flag==false){
                 flag=true;
                 >){
                     printf("ERROR: %s is not a legal number\n",str.c_str());
                     break;
                 }
             }
             '))){
                 printf("ERROR: %s is not a legal number\n",str.c_str());
                 break;
             }
         }
         if(j==len){
             double temp=stod(str);
              &&temp<=){
                 ans+=temp;
                 num++;
             }
             else{
                 printf("ERROR: %s is not a legal number\n",str.c_str());
             }
         }
     }
     ){
         printf("The average of %d numbers is %.2f\n",num,ans/num);
     }
     ){
         printf("The average of 0 numbers is Undefined\n");
     }
     ){
         printf("The average of %d number is %.2f\n",num,ans/num);
     }
     ;
 }