HDU 5675 ztr loves math

时间:2022-10-17 20:45:08

ztr loves math

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 896    Accepted Submission(s): 347

Problem Description
ztr loves research Math.One day,He thought about the "Lower Edition" of triangle equation set.Such as n = x2-y2.

He wanted to know that ,for a given number n,is there a positive integer solutions?

Input
There are T test cases.
The first line of input contains an positive integer T(T <= 106) indicating the number of test cases.

For each test case:each line contains a positive integer, n <= 1018.

Output

If there be a positive integer solutions,print "True", else print "False".

False

Sample Input
4
6
25
81
105
Sample Output
False
True
True
True
Hint

For the fourth case,$105 = 13^{2}-8^{2}$

Source
解析:枚举x和y,得到对应的n,打表找规律。
 #include <cstdio>

 long long n;
int t; int main()
{
scanf("%d",&t);
while(t--){
scanf("%I64d",&n);
if(n == || n == || n% == )
printf("False\n");
else
printf("True\n");
}
return ;
}