PAT甲级 1127. ZigZagging on a Tree (30)

时间:2023-03-09 10:04:23
PAT甲级 1127. ZigZagging on a Tree (30)

1127. ZigZagging on a Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However,
if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left.
For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

PAT甲级 1127. ZigZagging on a Tree (30)

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers
in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

—————————————————————————————————

题目的意思是给出一棵树的中序遍历和后序遍历,求奇数层反向输出偶数层正向输出的

层序遍历;

思路:先根据遍历建树,在层序输出奇偶分开讨论

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>
using namespace std; #define LL long long
const int INF = 0x3f3f3f3f;
int a[100005];
int b[100005];
struct node
{
int v,l,r,deep;
} tree[100005];
int n,cnt; int build(int l1,int r1,int l2,int r2,int deep)
{
if(l1>r1||l2>r2) return -1;
int ct=0;
for(int i=l1; i<=r1; i++)
{ if(a[i]==b[r2])
{
break;
}
ct++;
}
int x=cnt;
tree[cnt++].deep=deep;
tree[x].v=b[r2];
tree[x].l=build(l1,l1+ct-1,l2,l2+ct-1,deep+1);
tree[x].r=build(l1+ct+1,r1,l2+ct,r2-1,deep+1);
return x;
} int main()
{
scanf("%d",&n);
for(int i=0; i<n; i++)
scanf("%d",&a[i]);
for(int i=0; i<n; i++)
scanf("%d",&b[i]);
cnt=0;
int root=build(0,n-1,0,n-1,0);
queue<node>q;
stack<node>s;
node f;
q.push(tree[root]);
int fl=0;
while(!q.empty())
{
f=q.front();
q.pop();
if(f.l!=-1)
q.push(tree[f.l]);
if(f.r!=-1)
q.push(tree[f.r]);
if(f.deep%2==0)
{
s.push(f); }
else
{
while(!s.empty())
{
if(fl++)
printf(" ");
printf("%d",s.top().v);
s.pop();
}
if(fl++)
printf(" ");
printf("%d",f.v);
}
}
while(!s.empty())
{
if(fl++)
printf(" ");
printf("%d",s.top().v);
s.pop();
}
printf("\n");
return 0;
}