Divisors (求解组合数因子个数)【唯一分解定理】

时间:2023-03-09 08:10:07
Divisors (求解组合数因子个数)【唯一分解定理】

Divisors

题目链接(点击)

Your task in this problem is to determine the number of divisors of Cnk. Just for fun -- or do you need any special reason for such a useful computation?

Input

The input consists of several instances. Each instance consists of a single line containing two integers n and k (0 ≤ k ≤ n ≤ 431), separated by a single space.

Output

For each instance, output a line containing exactly one integer -- the number of distinct divisors of Cnk. For the input instances, this number does not exceed 2 63 - 1.

Sample Input

5 1
6 3
10 4

Sample Output

2
6
16

思路:

之前用求逆元的方法可以将组合数的最终值求出来,但是这个题目并没有给出要mod的值,所以先将结果求出来然后用唯一分解定理求因子个数的思路行不通。(即使求出来,结果也肯定会爆LL,导致根本无法将整个数保留下来求因子个数)

后来尝试将阶乘的前几个的值求出来然后求因子个数最后将 每个个数 相乘就得到结果

例如:C(9,3)

= 9 * 8 * 7

3 * 2 * 1

先将   9/3=3 的因子个数 2

8/2=4 的因子个数 3

7/1=7 的因子个数 2

然后   相乘 即: 2*3*2=12 即为答案

但是这样也是错的,因为这样 可能会导致后面的数分母不能化为1

例如: C(10,5)

= 10 * 9 * 8 * 7 * 6

5  * 4 * 3 * 2 * 1

先将10/5=2的 因子个数 2

9/4= ??这就错了

*************************************************************************************************************************************************

后来听同学的思路:

1.将1~431的每个素数个数用数组存起来

例: 10

sum[10][2]=1;

sum[10][3]=0;

sum[10][5]=1;

:

:

同时最好可以在打表的时候将n!对应素数个数直接存起来(特别好实现):

 num[i][prime[j]]=num[i-1][prime[j]]+count1  ///就可以了

2.求出分母的每个素数的个数

3.求出分子的每个素数的个数

4.将上面的数目对应相减就是最终值通过唯一分解定理得出的素数乘积

例:C(9,3)

9 =3^2               3=3^1

8=2^3                2=2^1

7=7^1                1=2^0

即:   3^2 * 2^3 * 7^1

3^1 * 2^1 * 2^0

结果: 3^1 * 7^1 * 2^2

所以:   (1+1)* (1+1) * (2+1)=12;

*************************************************************************************************************************************************

AC代码:

Divisors (求解组合数因子个数)【唯一分解定理】

#include<stdio.h>
typedef long long LL;
int prime[505],flag[505];
void allprime()
{
int count=0;
for(int i=2;i<=431;i++){
if(flag[i]==0){
prime[count++]=i;
}
for(int j=0;j<count&&prime[j]*i<=431;j++){
flag[i*prime[j]]=1;
if(i%prime[j]==0){
break;
}
}
}/// 82个
} //欧拉筛素数
int num[505][505];
int up,down;
int main()
{
allprime();
for(int i=1;i<=431;i++){
int num1=i;
for(int j=0;j<=82;j++){
int count1=0;
while(num1%prime[j]==0){
count1++;
num1/=prime[j];
}
num[i][prime[j]]=num[i-1][prime[j]]+count1;
}
} //打表
//printf("*%d\n",num[9][3]);
int n,k;
while(~scanf("%d%d",&n,&k)){
LL sum=1;
for(int i=0;i<=82;i++){
up=num[n][prime[i]]-num[n-k][prime[i]];
down=num[k][prime[i]];
sum*=(up-down+1);
}
printf("%lld\n",sum);
}
return 0;
}