pat02-线性结构2. 一元多项式求导 (25)

时间:2023-03-09 05:06:39
pat02-线性结构2. 一元多项式求导 (25)

02-线性结构2. 一元多项式求导 (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard

设计函数求一元多项式的导数。(注:xn(n为整数)的一阶导数为n*xn-1。)

输入格式:以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是0,但是表示为“0 0”。

输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0

提交代码

 #include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
using namespace std;
struct node{
int coe,ex;//系数,指数
node *next;
};
int main(){
//freopen("D:\\INPUT.txt","r",stdin);
node *h=new node(),*p,*r;
int coe,ex;
h->next=NULL;
r=h;
while(scanf("%d %d",&coe,&ex)!=EOF){
if(ex==){
continue;
}
coe=coe*ex;
ex-=;
p=new node();
p->coe=coe;
p->ex=ex;
p->next=NULL;
r->next=p;
r=p;
}
p=h->next;
if(p){
printf("%d %d",p->coe,p->ex);
p=p->next;
}
else{
printf("0 0\n");
return ;
}
while(p!=NULL){
printf(" %d %d",p->coe,p->ex);
p=p->next;
}
printf("\n");
return ;
}