Strange fuction
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4599 Accepted Submission(s):
3304
Problem Description
Now, here is a fuction:
F(x) = 6 *
x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value
when x is between 0 and 100.
F(x) = 6 *
x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value
when x is between 0 and 100.
Input
The first line of the input contains an integer
T(1<=T<=100) which means the number of test cases. Then T lines follow,
each line has only one real numbers Y.(0 < Y <1e10)
T(1<=T<=100) which means the number of test cases. Then T lines follow,
each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal
places),when x is between 0 and 100.
places),when x is between 0 and 100.
Sample Input
2
100
200
Sample Output
-74.4291
-178.8534
题解:先对方程求导,对求导后的方程求x,则此时由数学知识可得解除的x为原方程的一个极小值;带入原方程即可
#include<stdio.h>
#include<string.h>
#include<math.h>
double y;
double f(double x)
{
return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
double f1(double x)
{
return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x;
}
int main()
{
int t;
double l,r,mid,len;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&y);
l=0;r=100;mid;
while(r - l > 1e-8)
{
mid = ( r + l ) / 2;
if(f1(mid)<y)
l=mid;
else
r=mid;
}
len=f(r);
printf("%.4lf\n",len);
}
return 0;
}