HDU1069:Monkey and Banana(DP+贪心)

时间:2021-10-23 23:54:29
Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

 
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

 
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
 
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
 

题意:给出n个长方体的三边,求叠罗汉能叠的最高高度,要求上面长方体的底面积要小于下面的,每个长方体可以无限取

思路:用大了贪心的思想,由于n只有30,而且三边位置可以变化,可以将所有情况全部存起来再拍一次序,然后再将所有状况进行一次循环找出最大值

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std; struct node
{
int x,y,z;
} dp[35*3]; int hei[35*3]; int cmp(node a,node b)
{
if(a.x!=b.x)
return a.x<b.x;
if(a.y!=b.y)
return a.y<b.y;
a.z<b.z;
} int main()
{
int n,a,b,c,i,j,maxn,ans,cas = 1;
while(~scanf("%d",&n),n)
{
for(i = 0; i<n; i++)
{
scanf("%d%d%d",&a,&b,&c);
dp[i*3+0].x = a>b?a:b;
dp[i*3+0].y = a>b?b:a;
dp[i*3+0].z = c;
dp[i*3+1].x = b>c?b:c;
dp[i*3+1].y = b>c?c:b;
dp[i*3+1].z = a;
dp[i*3+2].x = a>c?a:c;
dp[i*3+2].y = a>c?c:a;
dp[i*3+2].z = b;
}
sort(dp,dp+3*n,cmp);
hei[0] = ans = dp[0].z;
for(i = 1; i<n*3; i++)
{
maxn = 0;
for(j = 0; j<i; j++)
{
if(dp[j].x<dp[i].x && dp[j].y<dp[i].y && hei[j]>maxn)
maxn = hei[j];
hei[i] = maxn+dp[i].z;
if(hei[i]>ans)
ans = hei[i]; }
}
printf("Case %d: maximum height = %d\n",cas++,ans);
} return 0;
}

HDU1069:Monkey and Banana(DP+贪心)的更多相关文章

  1. kuangbin专题十二 HDU1069 Monkey and Banana &lpar;dp&rpar;

    Monkey and Banana Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others ...

  2. HDU1069 Monkey and Banana —— DP

    题目链接:http://acm.split.hdu.edu.cn/showproblem.php?pid=1069 Monkey and Banana Time Limit: 2000/1000 MS ...

  3. HDU1069 Monkey and Banana

    HDU1069 Monkey and Banana 题目大意 给定 n 种盒子, 每种盒子无限多个, 需要叠起来, 在上面的盒子的长和宽必须严格小于下面盒子的长和宽, 求最高的高度. 思路 对于每个方 ...

  4. HDU 1069 Monkey and Banana &lpar;DP&rpar;

    Monkey and Banana Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u S ...

  5. HDU 1069 Monkey and Banana&lpar;DP 长方体堆放问题&rpar;

    Monkey and Banana Problem Description A group of researchers are designing an experiment to test the ...

  6. HDU 1069 Monkey and Banana dp 题解

    HDU 1069 Monkey and Banana 纵有疾风起 题目大意 一堆科学家研究猩猩的智商,给他M种长方体,每种N个.然后,将一个香蕉挂在屋顶,让猩猩通过 叠长方体来够到香蕉. 现在给你M种 ...

  7. HDU1069 - Monkey and Banana【dp】

    题目大意 给定箱子种类数量n,及对应长宽高,每个箱子数量无限,求其能叠起来的最大高度是多少(上面箱子的长宽严格小于下面箱子) 思路 首先由于每种箱子有无穷个,而不仅可以横着放,还可以竖着放,歪着放.. ...

  8. HDU1069 Monkey and Banana(dp)

    链接:http://acm.hdu.edu.cn/showproblem.php?pid=1069 题意:给定n种类型的长方体,每个类型长方体无数个,要求长方体叠放在一起,且上面的长方体接触面积要小于 ...

  9. HDU-1069 Monkey and Banana DAG上的动态规划

    题目链接:https://cn.vjudge.net/problem/HDU-1069 题意 给出n种箱子的长宽高 现要搭出最高的箱子塔,使每个箱子的长宽严格小于底下的箱子的长宽,每种箱子数量不限 问 ...

随机推荐

  1. 由浅入深学习ajax跨域&lpar;JSONP&rpar;问题

    什么是跨域?说直白点就是获取别人网站上的内容.但这么说貌似又有点混淆,因为通常我们用ajax+php就可以获取别人网站的内容,来看下面这个例子. 来看看跨域的例子,jquery+ajax是不能跨域请求 ...

  2. 使用proguard混淆java web项目代码

    1.首先下载proGuard.zip到本地: proguard4.5beta4.tar.zip解压开,2.新建文本文档,修改文件名为XXX.pro,然后复制下面内容到.pro -injars 'Y:\ ...

  3. CentOS 6&period;4下安装Oracle 11gR2

    安装前须知: 内存(RAM)的最小要求是 1GB,建议 2GB 及以上. 虚拟内存 swap 建议:内存为 1GB~2GB 时建议swap大小为内存大小的 1.5 倍:内存为 2GB~16GB 时建议 ...

  4. mysql优化(三)–explain分析sql语句执行效率

    mysql优化(三)–explain分析sql语句执行效率 mushu 发布于 11个月前 (06-04) 分类:Mysql 阅读(651) 评论(0) Explain命令在解决数据库性能上是第一推荐 ...

  5. 关于No architectures to compile for &lpar;ONLY&lowbar;ACTIVE&lowbar;ARCH&equals;YES&comma; active arch&equals;x86&lowbar;64&comma; VALID&lowbar;ARCHS&equals;armv7 armv7s&rpar;使用百度地图的解决办法

    出现的原因:armv7s是应用在iPhone 5 A6 的架构上的解决的方式:1,在Project target里“Architectures”设置为“Standard (armv7,armv7s)” ...

  6. boost ASIO实例

    client端代码 #include <iostream> #include <boost/asio.hpp> #include <boost/bind.hpp> ...

  7. 字符串和转为Data类型前后几天

    以防忘记:SimpleDateFormat 可以设置字符串的格式 package com.apploft.util.lang;import java.text.SimpleDateFormat;imp ...

  8. &lbrack;转&rsqb;docker之Dockerfile实践

    本文转自:https://www.cnblogs.com/jsonhc/p/7767669.html 上一篇介绍了Dockerfile中使用的指令,现在开始进行指令实践 先查看下本地的镜像,选一个作为 ...

  9. 关于找不到类org&sol;apache&sol;commons&sol;lang&sol;xwork&sol;StringUtils的问题

    在替换最新版的 struts2包的解决过程中.遇到 找不到这两个包org/apache/commons/lang/xwork/StringUtils.org/apache/commons/lang/x ...

  10. 电子相册之bitmap

    位图文件主要分为3部分:1. 文件信息头     14Byte 2. 位图信息头     40Byte 3. RGB颜色阵列   由图像长宽尺寸决定 1. 文件信息头 定义结构体: typedef s ...