1069 The Black Hole of Numbers(20 分)
For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174
-- the black hole of 4-digit numbers. This number is named Kaprekar Constant.
For example, start from 6767
, we'll get:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.
Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,104).
Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000
. Else print each step of calculation in a line until 6174
comes out as the difference. All the numbers must be printed as 4-digit numbers.
Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000
题目大意:给定一个四位数,展示出每位数从大到小排列,与从小到大排列的差值,直到出现6174黑洞数停止。
//这道题目是简单的,但是还是遇见了一些问题:
AC:
#include <iostream>
#include <algorithm>
#include <vector>
#include <stdlib.h>
#include<cstdio>
using namespace std; int main()
{
int n;
cin>>n;
int a[],big,small,res=-;
int temp=;
while(res!=)
{
fill(a,a+,);
while(n!=)
{
a[temp++]=n%;
n/=;
//cout<<"kk";
}
temp=;
sort(a,a+);//默认从小到大排列
small=a[]*+a[]*+a[]*+a[];
big=a[]*+a[]*+a[]*+a[];
if(a[]==a[]&&a[]==a[]&&a[]==a[])
{
printf("%04d - %04d = 0000\n",big,small);
return ;
}
res=big-small;
printf("%04d - %04d = %04d\n",big,small,res);
n=res;
}
return ;
}
1.第一次忽略了temp=0;应该在使用过后将其赋值为0的;
2. 应该将a数组初始化为0,要不然下次会有影响的,比如在有0位的时候:
3.最后就是提交发现第0个测试点过不去,原来是因为相同数的时候只输出了0,而不是0000!