hdu Phone List

时间:2022-05-27 17:21:08

Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

1. Emergency 911

2. Alice 97 625 999

3. Bob 91 12 54 26

In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.





Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number
is a sequence of at most ten digits.





Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.





Sample Input

2

3

911

97625999

91125426

5

113

12340

123440

12345

98346





Sample Output

NO

YES

算法:字典树

题意:给你一些单词让你判断这单词中,如果有单词作为另一个的前缀就输出NO;否则YES

代码:

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
using namespace std;
#define Max 20
struct dot
{
dot *next[Max];
int flag;
};
dot *newnode()
{
dot *temp=new dot;
int i;
temp->flag=0;
for(i=0;i<Max;i++)
temp->next[i]=NULL;
return temp;
}
void tree(char *st,dot *root,int &k)
{
int len=strlen(st);
dot *p=root;
int id=0;
for(int i=0;i<len;i++)
{
id=st[i]-'0'; if(p->next[id]==NULL)
p->next[id]=newnode();
if(p->flag)//例如之前出现单词abc,现在是abcd在这判断可以判断出
{
k=1;
return ;
}
p=p->next[id];
}
p->flag=1;
if(p->next[id]!=NULL)//例如之前出现abcd,现在是abc这在这判断出来
{
k=1;return ;
}
p->next[id]=newnode();
}
void del(dot *p)
{
if(p==0) return ;
for(int i=0;i<Max;i++)
if(p->next[i])
del(p->next[i]);
delete p;
}
int main()
{
int n,m,k;
char st[15];
scanf("%d",&n);
while(n--)
{ dot *root=new dot;
root=newnode();
scanf("%d",&m);
k=0;
while(m--)
{
scanf("%s",&st);
if(k==0)//如果还没出现单词为另一个单词的前缀这种情况,就继续建树
tree(st,root,k);
}
if(k) printf("NO\n");
else printf("YES\n");
del(root);
}
return 0;
}