杭电ACM 2052 Picture

时间:2023-03-08 19:20:36

Picture

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 16038    Accepted Submission(s): 8303

Problem Description
Give you the width and height of the rectangle,darw it.
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output
For each case,you should draw a rectangle with the width and height giving in the input.

after each case, you should a blank line.
Sample Input
3 2
Sample Output
+---+
| |
| |
+---+
#include<stdio.h>
int main()
{
int n,m,i,j;
while(scanf("%d%d",&m,&n)!=EOF)
{
printf("+");
for(i=1;i<=m;i++)
printf("-");
printf("+\n");
for(i=1;i<=n;i++)
{
printf("|");
for(j=1;j<=m;j++)
printf(" ");
printf("|\n");
}
printf("+");
for(i=1;i<=m;i++)
printf("-");
printf("+\n");
printf("\n");
}
return 0;
}