PAT甲 1012. The Best Rank (25) 2016-09-09 23:09 28人阅读 评论(0) 收藏

时间:2023-02-02 09:10:08

1012. The Best Rank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing
on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student
ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A


分别按每项排序,算出排名,然后查询时对4项的值


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std; struct node
{
int e,a,c,m,ne,na,nc,nm,id;
} s[2003]; bool cmpa(node a,node b)
{
return a.a>b.a;
} bool cmpc(node a,node b)
{
return a.c>b.c;
} bool cmpm(node a,node b)
{
return a.m>b.m;
} bool cmpe(node a,node b)
{
return a.e>b.e;
} int main()
{
int m,n,C,E,M,id;
scanf("%d%d",&n,&m);
memset(s,-1,sizeof(s));
for(int i=0; i<n; i++)
{
scanf("%d%d%d%d",&id,&C,&M,&E);
s[i].id=id;
s[i].c=C;
s[i].m=M;
s[i].e=E;
s[i].a=(C+M+E)/3;
}
sort(s,s+n,cmpa);
int cnt=0;
while(s[cnt].a!=-1)
{
if(s[cnt].a==s[cnt-1].a)
s[cnt].na=s[cnt-1].na;
else
s[cnt].na=cnt+1;
cnt++;
}
sort(s,s+n,cmpc);
cnt=0;
while(s[cnt].c!=-1)
{
if(s[cnt].c==s[cnt-1].c)
s[cnt].nc=s[cnt-1].nc;
else
s[cnt].nc=cnt+1;
cnt++;
}
sort(s,s+n,cmpm);
cnt=0; while(s[cnt].m!=-1)
{
if(s[cnt].m==s[cnt-1].m)
s[cnt].nm=s[cnt-1].nm;
else
s[cnt].nm=cnt+1;
cnt++;
} sort(s,s+n,cmpe);
cnt=0;
while(s[cnt].e!=-1)
{
if(s[cnt].e==s[cnt-1].e)
s[cnt].ne=s[cnt-1].ne;
else
s[cnt].ne=cnt+1;
cnt++;
} for(int i=0; i<m; i++)
{
scanf("%d",&id);
int flag=-1;
for(int j=0;j<n;j++)
{
if(s[j].id==id)
{
flag=j;
break;
}
}
if(flag==-1)
printf("N/A\n");
else if(s[flag].na<=s[flag].nc&&s[flag].na<=s[flag].nm&&s[flag].na<=s[flag].ne)
printf("%d A\n",s[flag].na);
else if(s[flag].nc<s[flag].na&&s[flag].nc<=s[flag].nm&&s[flag].nc<=s[flag].ne)
printf("%d C\n",s[flag].nc);
else if(s[flag].nm<s[flag].na&&s[flag].nm<s[flag].nc&&s[flag].nm<=s[flag].ne)
printf("%d M\n",s[flag].nm);
else if(s[flag].ne<s[flag].na&&s[flag].ne<s[flag].nc&&s[flag].ne<s[flag].nm)
printf("%d E\n",s[flag].ne);
}
return 0;
}