Check the difficulty of problems

时间:2021-04-26 23:17:00

Check the difficulty of problems

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 5830 Accepted: 2542

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:

1. All of the teams solve at least one problem.

2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2

0.9 0.9

1 0.9

0 0 0

Sample Output

0.972

概率DP.

题意:有t支队伍,m道题,冠军最少做n道题,问保证每队最少做一题,冠军最少做n题的概率

思路:下面转载别人博客中的解释,很详细,基本上看着这个思路,将之代码化就能过,注意精度。

可以知道,每个人自己是互不影响的 对于一个选手 i 前 j 道题,做出 k 道题的概率F[i][j][k] = F[i][j - 1][k - 1] * p[i][j] + F[i][j - 1][k] * (1 - p[i][j])

那么问题可以转化为:所有至少做出一道的概率(p1) - 所有选手做出的题数n >= 1 && n < N 的概率(p2)

设s[i][j]表示F[i][M][0] + F[i][M][1] + … + F[i][M][j]

P1 = (s[1][M] - s[1][0])(s[2][M]-s[2][0])…*(s[T][M]-s[T][0])

P2 = (s[1][N-1] - s[1][0])(s[2][N-1]-s[2][0])…*(s[T][N-1]-s[T][0])

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm> using namespace std; typedef long long LL; const int MAX = 1100; double Dp[MAX][35][35]; double a[MAX][35]; double s[MAX][35]; int main()
{
int n,m,T;
while(scanf("%d %d %d",&m,&T,&n)&&(n+m+T))
{
for(int i=1;i<=T;i++)
{
for(int j=1;j<=m;j++)
{
scanf("%lf",&a[i][j]);//第i队作对第j道题的概率
}
}
memset(Dp,0,sizeof(Dp));
memset(s,0,sizeof(s));
for(int i=1;i<=T;i++)
{
Dp[i][0][0]=1.0;
for(int j=1;j<=T;j++)
{
Dp[i][j][0]=Dp[i][j-1][0]*(1-a[i][j]);//第i队前j道题一道题都没有做对
}
for(int j=1;j<=m;j++)
{
for(int k=1;k<=j;k++)
{
Dp[i][j][k]=Dp[i][j-1][k-1]*a[i][j]+Dp[i][j-1][k]*(1-a[i][j]);//第i队前j道题做对k道题的概率
}
}
s[i][0]=Dp[i][m][0];//一道题都没有做对的概率
for(int j=1;j<=m;j++)
{
s[i][j]=s[i][j-1]+Dp[i][m][j];//做对1~j道题的概率
}
}
double pp=1.0;//都做对1~m道题的概率
double ppp=1.0;//都做对1~n-1道题的概率
for(int i=1;i<=T;i++)
{
pp*=(s[i][m]-s[i][0]);
ppp*=(s[i][n-1]-s[i][0]);
}
printf("%.3f\n",pp-ppp);//都至少做一道题,并且至少一个对做对的题数大于n
} return 0;
}