POJ 3278 Catch That Cow(bfs)

时间:2022-09-25 21:35:26
Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 80273   Accepted: 25290

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

思路

题意:给定起点和终点,有三种走的方式,假设当前为 now,那么可以选择下一次到达 now - 1 或 now + 1  或 2*now,问起点到终点最少需要几步。

题解:bfs,下一个状态即为三种可选择的位置。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 100005;
int step[maxn],que[maxn],vis[maxn];

int bfs(int st,int ed)
{
	int E = 0,F = 0;
	que[F++] = st;
	vis[st] = 1;
	for (;;)
	{
		int now = que[E];
		if (now == ed)	return step[now];
		if (now + 1 < maxn && !vis[now + 1])	step[now + 1] = step[now] + 1,vis[now + 1] = 1,que[F++] = now + 1;
		if (now - 1 >= 0 &&!vis[now - 1])	step[now - 1] = step[now] + 1,vis[now - 1] = 1,que[F++] = now - 1;
		if (2*now < maxn && !vis[2*now])	step[2*now] = step[now] + 1,vis[2*now] = 1,que[F++] = 2 * now;
		E++;
	}
}

int main()
{
	int N,K;
	memset(vis,0,sizeof(vis));
	scanf("%d%d",&N,&K);
	if (N >= K)	printf("%d\n", N - K);
	else	printf("%d\n",bfs(N,K));
	return 0;
}