HDU 1754——I Hate It——————【线段树单点替换、区间求最大值】

时间:2022-07-14 19:43:56
I Hate It

Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。 
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

 

Input

本题目包含多组测试,请处理到文件结束。 
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。 
学生ID编号分别从1编到N。 
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。 
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。 
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。 
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。 
 

Output

对于每一次询问操作,在一行里面输出最高成绩。
 

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5
 

Sample Output

5
6
5
9

Hint

Huge input,the C function scanf() will work better than cin 
 
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=210000;
int maxv[maxn*4];
#define mid (L+R)/2
#define lson rt*2,L,mid
#define rson rt*2+1,mid+1,R
void PushUP(int x){ maxv[x]=max(maxv[x*2],maxv[x*2+1]);
}
void build(int rt,int L,int R){ if(L==R){ scanf("%d",&maxv[rt]);
}else{ build(lson);
build(rson);
PushUP(rt);
}
}
void update(int rt,int L,int R,int x,int v){ if(L==R){ maxv[rt]=v;
return ;
}
if(mid>=x)
update(lson,x,v);
else
update(rson,x,v);
PushUP(rt);
}
int query(int rt,int L,int R,int lp,int rp){ if(lp<=L&&R<=rp){ return maxv[rt];
}
int ret=0;
if(lp<=mid){ ret=max(ret,query(lson,lp,rp));
}
if(rp>mid){ ret=max(ret,query(rson,lp,rp));
}
return ret;
}
int main(){ int n,m;
char tms[5];
while(scanf("%d%d",&n,&m)!=EOF){ memset(maxv,0,sizeof(maxv));
build(1,1,n);
for(int i=0;i<m;i++){ int a,b,ans;
scanf("%s%d%d",tms,&a,&b);
if(tms[0]=='Q'){ ans=query(1,1,n,a,b);
printf("%d\n",ans);
}else{ update(1,1,n,a,b);
}
} } return 0;
}