PAT - 测试 01-复杂度2 Maximum Subsequence Sum (25分)

时间:2023-01-02 17:51:59

1​​, N2N_2N​2​​, ..., NKN_KN​K​​ }. A continuous subsequence is defined to be { NiN_iN​i​​, Ni+1N_{i+1}N​i+1​​, ..., NjN_jN​j​​ } where 1≤i≤j≤K1 \le i \le j \le K1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

PAT - 测试  01-复杂度2 Maximum Subsequence Sum   (25分)

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer KKK (≤10000\le 10000≤10000). The second line contains KKK numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices iii and jjj (as shown by the sample case). If all the KKK numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

),第二行输入KKK个数,以空格为分割。输出:对于每一个测试的情况下,在一个行中的最大总和的输出,与第一和最大序列的最后数字。数字必须用一个空格分开,但最后一个数后没有空格。在该最大序列不是唯一的情况下,输出一个具有最小索引的数。如果输入的所有的数都是负数,则它的最大总和被定义为0,你应该输出的第一和整个序列的最后一个数。============================第一次code:

 #include <stdio.h>
 #include <stdlib.h>

 void MaxSubseSum(int n);
 int main(void)
 {
     int n;
     scanf("%d",&n);
     MaxSubseSum(n);
     ;
 }
 void MaxSubseSum(int n)
 {
     ,MaxSum=,start=,end=,start1=,flag=;
     int a[n];
     ;i<n;i++)
     {
        scanf("%d",&a[i]);
     }
     ;i<n;i++)
     {
         ThisSum += a[i];
         )
         flag = ;
         if(ThisSum > MaxSum)
         {
             start = start1;
             MaxSum = ThisSum;
             end = i;
         }
         )
         {
             ThisSum = ;
             start1=i+;
         }
     }
     )
     {
         )
         {
             printf(],a[n-]);
         }
        else
         {
             printf("0 0 0");
         }
     }
     else
     {
         printf("%d %d %d",MaxSum,a[start],a[end]);
     }
 }


PAT - 测试  01-复杂度2 Maximum Subsequence Sum   (25分)