自测-4 Have Fun with Numbers(20 分)

时间:2022-11-10 17:03:27

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

思路:

1.用一个哈希表ht[]标记数字出现的次数,原数字中出现则ht++,结果中出现则ht--,最后如果ht全部为零则输出Yes,否则输出No。
2.以字符串形式读入数据,定义一个数据乘2的函数,注意处理后需要逆转一次结果串。

参考代码:

#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
int ht[10]={0};
string DoubleS(string str)
{
	int temp=0,r,carry=0;
	string result="";
	for(int i=str.size()-1;i>=0;i--)
	{
		ht[str[i]-'0']++;
		r=(str[i]-'0')*2+carry;
		carry=r/10;
		ht[r%10]--;
		result+=(r%10+'0');
	}
	if(carry!=0) 
	{
		result+=(carry+'0');
		ht[carry]--;
	}
	reverse(result.begin(),result.end());
	return result;
}
int main()
{
	string ori,res;
	cin>>ori;
	res=DoubleS(ori);
	bool flag=true;
	for(int i=0;i<res.size()&&flag;i++)
	{
		if(ht[i]!=0) flag=false;
	}
	if(flag) cout<<"Yes\n";
	else cout<<"No\n";
	cout<<res<<endl;
	return 0;
}