I-MooFest(POJ 1990)

时间:2022-06-20 14:49:03
MooFest
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 5697   Accepted: 2481

Description

Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing.

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)).

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume.

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location.

Output

* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows. 

Sample Input

4
3 1
2 5
2 6
4 3

Sample Output

57

Source

 
读题真是个大问题啊!!!一开始读了好久也没读懂,还是看的别人题解才明白了题意。
好吧,题意好歹明白了,可是问题又来了,怎么办?
归根到底就是一个动态改值并求和的问题,树状数组(线段树当然也可)。
我发现我的树状数组真不会用,就是用的不熟练,以前做的都直接套,我都没弄懂啥意思,一次锻炼吧。
往往成功就差那么一步啊,确是咫尺天涯。
#include <cstdio>
#include <iostream>
#include <sstream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <string>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
#define ll long long
#define _cle(m, a) memset(m, a, sizeof(m))
#define repu(i, a, b) for(int i = a; i < b; i++)
#define MAXN 20005 struct P{
ll v, p;
bool operator < (const P& t) const {
return t.v > v;
}
}cow[MAXN];
ll c_ount[MAXN] = {};
ll total[MAXN] = {};
ll sum_tot[MAXN] = {};
int n; ll lowbit(ll x)
{
return x & (-x);
} void add(int x, int d, ll c[])
{
while(x < MAXN) {
c[x] += d;
x += lowbit(x);
}
} ll Sum(ll x, ll c[])
{
ll ret = ;
while(x > )
{
ret += c[x];
x -= lowbit(x);
}
return ret;
} int main()
{
scanf("%d", &n);
repu(i, , n + ) scanf("%lld%lld", &cow[i].v, &cow[i].p);
sort(cow + , cow + n + );
repu(i, , n + ) sum_tot[i] = sum_tot[i - ] + cow[i].p;
ll sum = , num_cow = , sum_total = ;
add(cow[].p, , c_ount);
add(cow[].p, cow[].p, total);
repu(i, , n + ) {
num_cow = Sum(cow[i].p, c_ount);
sum_total = Sum(cow[i].p, total);
sum += cow[i].v * (num_cow * cow[i].p - sum_total
+ (sum_tot[i - ] - sum_total - (i - - num_cow) * cow[i].p));
add(cow[i].p, , c_ount);
add(cow[i].p, cow[i].p, total);
}
printf("%lld\n", sum);
return ;
}