13:将字符串中的小写字母转换成大写字母

时间:2023-01-02 09:12:01

原题链接

总时间限制: 
1000ms 
内存限制: 
65536kB
描述

给定一个字符串,将其中所有的小写字母转换成大写字母。

输入
输入一行,包含一个字符串(长度不超过100,可能包含空格)。
输出
输出转换后的字符串。
样例输入
helloworld123Ha
样例输出
HELLOWORLD123HA

源码

#include <iostream>
#include <iomanip>
#include <cstring>
using namespace std;
int main()
{
char str[100];
int i,len;
gets(str);
len = strlen(str);
for (i=0;i<len;i++){
if (str[i]>='a' && str[i]<='z'){
str[i] += 'A'-'a';
}
}
cout << str;
return 0;
}

13:将字符串中的小写字母转换成大写字母