【杭电oj2026】首字母变大写

时间:2022-12-28 09:04:36

首字母变大写

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 50133    Accepted Submission(s): 27724


Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 

Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 

Output
请输出按照要求改写后的英文句子。
 

Sample Input
 
 
i like acm i want to get an accepted
 

Sample Output
 
 
I Like Acm I Want To Get An Accepted
 

Author
lcy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1000  1020  1379  2048  1008 
 


#include<stdio.h>
#include<string.h>
int main() {
    char a[120];
    while(gets(a)!=NULL) {
        int i=1,j,l=0;
        while(l<strlen(a)) {
            if(a[l]==' ')
                i=1;
            else if(i==1&&a[l]!=' ') {
                a[l]-=32;
                i=0;
            }
            l++;
        }
        printf("%s\n",a);
    }
    return 0;
}

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=2026