Team Queue(多队列技巧处理)

时间:2023-02-15 08:39:24

Team Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2009    Accepted Submission(s): 696

Problem Description
Queues
and Priority Queues are data structures which are known to most
computer scientists. The Team Queue, however, is not so well known,
though it occurs often in everyday life. At lunch time the queue in
front of the Mensa is a team queue, for example.
In a team queue
each element belongs to a team. If an element enters the queue, it first
searches the queue from head to tail to check if some of its teammates
(elements of the same team) are already in the queue. If yes, it enters
the queue right behind them. If not, it enters the queue at the tail and
becomes the new last element (bad luck). Dequeuing is done like in
normal queues: elements are processed from head to tail in the order
they appear in the team queue.

Your task is to write a program that simulates such a team queue.

 
Input
The
input will contain one or more test cases. Each test case begins with
the number of teams t (1<=t<=1000). Then t team descriptions
follow, each one consisting of the number of elements belonging to the
team and the elements themselves. Elements are integers in the range 0 -
999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.

 
Output
For
each test case, first print a line saying "Scenario #k", where k is the
number of the test case. Then, for each DEQUEUE command, print the
element which is dequeued on a single line. Print a blank line after
each test case, even after the last one.
 
Sample Input
2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0
 
Sample Output
Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

 题解:题意就是一个队列相同组的可以插队,插到相同队员的后面,思路是弄多个队列,用一个队列来确定队编号的序列,一个数组判断当前队是否还有队员,没有队员标记为空;
代码:
import java.util.HashMap;
import java.util.LinkedList;
import java.util.Scanner; public class hdu1387 {
static Scanner cin = new Scanner(System.in);
private static HashMap<Integer, Integer>mp = new HashMap<Integer, Integer>();
private static LinkedList<Integer>q[] = new LinkedList[1010];
private static int vis[] = new int[1010];
static{
for(int i = 0; i < q.length; i++){
q[i] = new LinkedList<Integer>();
}
}
public static void main(String[] args) {
int t, n, e, i, kase = 1;
while((t = cin.nextInt()) != 0){
init(t);
for(i = 0; i < t; i++){
n = cin.nextInt();
while(n-- > 0){
e = cin.nextInt();
mp.put(e, i);
}
}
String command;
System.out.println("Scenario #" + kase++);
while(!(command = cin.next()).equals("STOP")){
if("ENQUEUE".equals(command)){
e = cin.nextInt();
i = mp.get(e);
q[i].add(e);
if(vis[i] == 0){
q[t].add(i);
vis[i] = 1;
}
//0 1 0 0 1 0 1 1
}
else{
i = q[t].getFirst();
while(q[i].isEmpty()){
q[t].poll();
vis[i] = 0;
i = q[t].getFirst();
}
e = q[i].getFirst();
q[i].poll();
System.out.println(e);
}
}
System.out.println();
} }
private static void init(int t) {
for(int i = 0; i <= t; i++){
q[i].clear();
}
for(int i = 0; i < 1010; i++){
vis[i] = 0;
}
mp.clear();
}
}