poj1141Brackets Sequence【区间dp+路径记录】

时间:2022-12-29 08:13:48
Brackets Sequence
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 27420   Accepted: 7765   Special Judge

Description

Let us define a regular brackets sequence in the following way:

1. Empty sequence is a regular sequence.
2. If S is a regular sequence, then (S) and [S] are both regular sequences.
3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]
题意:给出一个括号串输出将他们匹配后的结果要求添加最少的括号
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
char str[110];
int dp[110][110];//第i-第j最大配对括号数
int pos[110][110];//第i-第j间加括号的位置
void print(int left,int right)
{
if(left>right)return ;
if(left==right)
{
if(str[left]=='('||str[left]==')')
printf("()");
else
printf("[]");
}
else
{
if(pos[left][right]==-1)
{
putchar(str[left]);
print(left+1,right-1);
putchar(str[right]);
}
else
{
print(left,pos[left][right]);
print(pos[left][right]+1,right);
}
}
}
int main()
{
int i,j,k,l,len;
while(gets(str))
{
l=strlen(str);
memset(dp,0,sizeof(dp));
for(len=1;len<l;++len)
{
for(i=0,j=len;j<l;++j,++i)
{
if((str[i]=='('&&str[j]==')')||(str[i]=='['&&str[j]==']'))
{
dp[i][j]=dp[i+1][j-1]+2;
pos[i][j]=-1;//括号已配对不加括号
}
for(k=i;k<j;++k)
{
if(dp[i][k]+dp[k+1][j]>=dp[i][j])
{
dp[i][j]=dp[i][k]+dp[k+1][j];
pos[i][j]=k;//在k处需要加括号
}
}
}
}
print(0,l-1);
putchar('\n');
}
return 0;
}