HDU 4006 优先队列

时间:2022-10-02 06:33:24

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 10390    Accepted Submission(s): 4153

Problem Description
Xiao
Ming and Xiao Bao are playing a simple Numbers game. In a
round Xiao Ming can choose to write down a number, or ask
Xiao Bao what the kth great number is. Because the number
written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to
help Xiao Bao.
 
Input
There
are several test cases. For each test case, the first line of input
contains two positive integer n, k. Then n lines follow. If Xiao Ming
choose to write down a number, there will be an " I" followed by a
number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao
Bao, there will be a "Q", then you need to output the kth great number.
 
Output
The output consists of one integer representing the largest number of islands that all lie on one line.
 
Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
 
Sample Output
1
2
3
Hint

Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).

 
Source
题意:
共有n种操作,I插入一个数,Q询问第K大的数是几。
代码:
学会了优先队列
 #include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<functional>
#include<vector>
using namespace std;
int n,k;
int main()
{
char ch[];
int x;
while(scanf("%d%d",&n,&k)!=EOF)
{
priority_queue<int,vector<int>,greater<int> >que;
while(n--)
{
scanf("%s",ch);
if(ch[]=='I')
{
scanf("%d",&x);
que.push(x);
}
else
{
printf("%d\n",que.top());
}
if(que.size()>k)
que.pop();
}
}
return ;
}