【POJ】1663 - Number Steps(找规律)

时间:2022-10-15 04:23:31

点击打开题目

Number Steps
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 13816   Accepted: 7470

Description

Starting from point (0,0) on a plane, we have written all non-negative integers 0,1,2, ... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued. 
【POJ】1663 - Number Steps(找规律)

You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

Input

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

Output

For each point in the input, write the number written at that point or write No Number if there is none.

Sample Input

3
4 2
6 6
3 4

Sample Output

6
12
No Number

Source




WA的一次心服口服,刚开始只是判断 x ,y 的奇偶性是否相同,后来发现并不能这么判断,UVALive 的数据比较弱,POJ的强一点。


代码如下:

#include <cstdio>
int main()
{
	int u;
	int x,y;
	scanf ("%d",&u);
	while (u--)
	{
		scanf ("%d %d",&x,&y);
		if (x != y && x != y + 2)
		{
			printf ("No Number\n");
			continue;
		}
		if (x & 1)
		{
			if (x == y)
				printf ("%d\n",2 * x - 1);
			else
				printf ("%d\n",2 * x - 3);
		}
		else
		{
			if (x == y)
				printf ("%d\n",2 * x);
			else
				printf ("%d\n",2 * x - 2);
		}
	}
	return 0;
}