hdoj.1093 A+B for Input-Output Practice (V) 20140721

时间:2022-09-12 04:04:40

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46323    Accepted Submission(s): 31412


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
 

Sample Input
 
 
2 4 1 2 3 4 5 1 2 3 4 5
 

Sample Output
 
 
10 15
 
#include<stdio.h>
int main()
{
    int m,n,a,sum;
    scanf("%d",&m);
    while(m--){
        scanf("%d",&n);
        sum=0;
        while(n--){
            scanf("%d",&a);
            sum+=a;
        }
        printf("%d\n",sum);
    }
    return 0;
}