2015 多校联赛 ——HDU5302(构造)

时间:2021-05-10 03:50:40

Connect the Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 108    Accepted Submission(s): 36
Special Judge

Problem Description
Once there was a special graph. This graph had n vertices
and some edges. Each edge was either white or black. There was no edge connecting one vertex and the vertex itself. There was no two edges connecting the same pair of vertices. It is special because the each vertex is connected to at most two black edges and
at most two white edges.

One day, the demon broke this graph by copying all the vertices and in one copy of the graph, the demon only keeps all the black edges, and in the other copy of the graph, the demon keeps all the white edges. Now people only knows there are w0 vertices
which are connected with no white edges, w1 vertices
which are connected with 1 white
edges, w2 vertices
which are connected with 2 white
edges, b0 vertices
which are connected with no black edges, b1 vertices
which are connected with 1 black
edges and b2 vertices
which are connected with 2 black
edges.

The precious graph should be fixed to guide people, so some people started to fix it. If multiple initial states satisfy the restriction described above, print any of them.

 
Input
The first line of the input is a single integer T (T≤700),
indicating the number of testcases.

Each of the following T lines
contains w0,w1,w2,b0,b1,b2.
It is guaranteed that 1≤w0,w1,w2,b0,b1,b2≤2000 and b0+b1+b2=w0+w1+w2.

It is also guaranteed that the sum of all the numbers in the input file is less than 300000.

 
Output
For each testcase, if there is no available solution, print −1.
Otherwise, print m in
the first line, indicating the total number of edges. Each of the next m lines
contains three integers x,y,t,
which means there is an edge colored t connecting
vertices x and y. t=0 means
this edge white, and t=1 means
this edge is black. Please be aware that this graph has no self-loop and no multiple edges. Please make sure that 1≤x,y≤b0+b1+b2.
 
Sample Input
2
1 1 1 1 1 1
1 2 2 1 2 2
 
Sample Output
-1
6
1 5 0
4 5 0
2 4 0
1 4 1
1 3 1
2 3 1
 
Source
 

题意:构造一个图使其满足:

白边:入度为0的数目为a[0],入度为1的数目为a[1],入度为2的数目为a[2],黑边同理。

思路:

入度为1的点必定为偶数,否则输出-1

点的总数:a[0] + a[1] + a[2]

边的总数 = 入度总数 /2  = (a[1]+b[1])/2 + a[2] + b[2]

入度为二的:(1,2)(2,3)(3,4).... 所以 a[2] >= 0

入度为一的: (1,2)(3,4).....    而且构造入度为二的链会有2个入度1,所以吧a[1] > 2

黑色边的处理需要间隔2的跳变(图中两点之间只有一条边)

//学习的别人的代码,把感觉能做题的都写一遍吧,当然那种代码长而且没法理解了,咳咳。。。  以后再说

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <vector>
int MAX=0x3f3f3f3f;
using namespace std;
const int INF = 0x7f7f7f;
const int MAXM = 12e4+5; int p[1000005];
int a[3],b[3]; int main()
{ int T;
scanf("%d",&T);
while(T--)
{
scanf("%d %d %d %d %d %d",&a[0],&a[1],&a[2],&b[0],&b[1],&b[2]);
int sum = 0;
for(int i = 0; i < 3; i++)
sum+=a[i]; if((a[1] & 1) || (b[1] & 1))
{
printf("-1\n");
continue;
} int n = (a[1]/2 + a[2]+b[1]/2 + b[2]); if(sum==4)
{
printf("4\n1 2 0\n1 3 0\n2 3 1\n3 4 1\n");
continue;
} printf("%d\n",n);
int t = 1;
while(a[2] >=0)
{
printf("%d %d 0\n",t,t+1);
t++;
a[2]--;
}
t++;
while(a[1] > 2)
{
printf("%d %d 0\n",t,t+1);
t+=2;
a[1]-=2;
}
int tmp = 0;
for(int i = 1;i <= sum ;i+=2) p[tmp++] = i;
for(int i = 2;i <= sum;i+=2) p[tmp++] = i; tmp = 0;
while(b[2] >= 0)
{
printf("%d %d 1\n",min(p[tmp],p[tmp+1]),max(p[tmp],p[tmp+1]));
tmp++;
b[2]--;
}
tmp ++;
while(b[1] > 2)
{
printf("%d %d 1\n",min(p[tmp],p[tmp+1]),max(p[tmp],p[tmp+1]));
tmp+=2;
b[1]-=2;
} }
return 0;
}