【贪心算法】POJ-2393 简单贪心水题

时间:2022-03-07 03:22:40

一、题目

Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week.

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt.

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.

Input

  • Line 1: Two space-separated integers, N and S.

  • Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

Output

  • Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5

88 200

89 400

97 300

91 500

Sample Output

126900

Hint

OUTPUT DETAILS:

In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units.

二、思路&心得

  • 这题确实有点水,数据也很弱,比较的应该不只是相邻两周的数据,之后的应该也要比较,但是两种代码都能AC,这就有趣了。。。
  • 我的代码比较麻烦点,还有更简单复杂度更小为O(N)的解法,扫描时维护一个min值就行了,每次进入循环时自加S,然后和当前周的Y进行比较取其中最小的即可。

三、代码

解法一:

#include<cstdio>
#include<algorithm>
#define MAX_N 10005
using namespace std; struct Week {
int C;
int Y;
int visit;
} W[MAX_N]; int N, S; long long cost; void solve() {
cost = 0;
for (int i = 0; i < N; i ++) {
scanf("%d %d", &W[i].C, &W[i].Y);
}
for (int i = 0; i < N; i ++) {
if (!W[i].visit) {
cost += W[i].C * W[i].Y;
W[i].visit = 1;
for (int j = i + 1; j < N; j ++) {
if ((W[i].C + (j - i) * S) <= W[j].C) {
cost += (W[i].C + (j - i) * S) * W[j].Y;
W[j].visit = 1;
} else {
break;
}
}
}
}
printf("%lld\n", cost);
} int main() {
scanf("%d %d", &N, &S);
solve();
return 0;
}

解法二:

#include <cstdio>
typedef long long ll;
struct AC{
ll c,y;
}r[11000];
ll n,s;
int main(){
scanf("%d%d",&n,&s);
for (int i=1;i<=n;i++)
scanf("%d%d",&r[i].c,&r[i].y);
ll ans=0,min=1<<30;
for (int i=1;i<=n;i++){
min+=s;
if (min>r[i].c)
min=r[i].c;
ans+=min*r[i].y;
}
printf("%lld",ans);
return 0;
}