POJ 3311 Hie with the Pie(状压DP + Floyd)

时间:2020-12-14 22:15:15

题目链接:http://poj.org/problem?id=3311

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before
he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you
to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating
the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting
any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from
location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source

PS:

  1. //Floyd + 状态压缩DP
  2. //题意是有N个城市(1~N)和一个PIZZA店(0),要求一条回路。从0出发,又回到0,并且距离最短
  3. //也就是TSP(旅行商)问题,首先不难想到用FLOYD先求出随意2点的距离dis[i][j]
  4. //接着枚举全部状态,用11位二进制表示10个城市和pizza店,1表示经过,0表示没有经过
  5. //定义状态DP(i,j)表示在i状态下。到达城市j的最优值

题意解说什么的都去看:http://blog.csdn.net/chinaczy/article/details/5890768

代码例如以下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 17;
int d[maxn][maxn];
int dp[1<<maxn][maxn];
//dp[i][j]:i状态下,到达j城市的最短时间
#define INF 0x3f3f3f3f
int n;
void Floyd()
{
for(int k = 0; k <= n; k++)
{
for(int i = 0; i <= n; i++)
{
for(int j = 0; j <= n; j++)
{
if(d[i][j] > d[i][k]+d[k][j])
{
d[i][j] = d[i][k]+d[k][j];
}
}
}
}
}
int main()
{
while(scanf("%d",&n) && n)
{
for(int i = 0; i <= n; i++)
{
for(int j = 0; j <= n; j++)
{
scanf("%d",&d[i][j]);
}
}
Floyd();//跑出各点之间的最短距离 for(int i = 0; i <= (1<<n)-1; i++)
{
for(int j = 1; j <= n; j++)
{
if(i == (1<<(j-1)))//边界;
{
//状态i仅仅经过城市j则直接到达城市j
dp[i][j] = d[0][j];
}
else
{
dp[i][j] = INF;
}
}
}
for(int i = 0; i <= (1<<n)-1; i++)
{
for(int j = 1; j <= n; j++)
{
if(i & (1<<(j-1)))//状态i中已经经过城市j
{
for(int k = 1; k <= n; k++)//枚举中间城市找最小的距离
{
if(i&(1<<(k-1)) && j!=k)//枚举不是城市j的其它城市作为中间城市
{
//i^(1<<(j-1))表示未到达城市j的状态(使表示j这位的二进制变为0,注意第二层for的if())
dp[i][j] = min(dp[i][j],dp[i^(1<<(j-1))][k]+d[k][j]);
}
}
}
}
}
int ans_min = dp[(1<<n)-1][1]+d[1][0];
for(int i = 2; i <= n; i++)
{
if(ans_min > dp[(1<<n)-1][i]+d[i][0])
{
ans_min = dp[(1<<n)-1][i]+d[i][0];
}
}
printf("%d\n",ans_min);
}
return 0;
}