hdu 2117:Just a Numble(水题,模拟除法运算)

时间:2022-07-26 19:56:56

Just a Numble

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2107    Accepted Submission(s): 987

Problem Description
Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed
 
Input
Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)
 
Output
For each line of input, your program should print a numble on a line,according to the above rules
 
Sample Input
4 2
5 7
123 123
 
Sample Output
5
8
 
Author
YBB
 
Source
 
Recommend
威士忌   |   We have carefully selected several similar problems for you:  2114 2115 2116 2113 2119 
 

 
  水题,但也要动动脑子。
  模拟除法的运算。输入两个数n和m,求出1/n的小数点后的第m位数。
  代码:
 #include <iostream>

 using namespace std;
int main()
{
int n,m;
while(cin>>n>>m){
if(n==){
cout<<<<endl;
continue;
}
int num = ;
int d = ;
int dn = ;
while(d!=m){
dn = num/n;
num = num%n;
num*=;
++d;
}
cout<<dn<<endl;
}
return ;
}

Freecode : www.cnblogs.com/yym2013