zoj 3829 Known Notation(2014在牡丹江区域赛k称号)

时间:2022-07-01 16:24:12

Known Notation


Time Limit: 2 Seconds      Memory Limit: 131072 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression
follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there
are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix
expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence
which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations
to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2

先算最少加入的数, 再交换。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int N = 1111;
int main()
{
int T;
scanf("%d", &T);
while (T--)
{
char s[N];
scanf("%s", s);
int totNum = 0, totChar = 0;
int len = (int) strlen(s);
int flag = 0;
for (int i = 0; i < len && !flag; ++i)
if (s[i] == '*') flag = 1;
if (!flag)
{
cout << 0 << endl;
continue;
}
int ans = 0;
for (int i = 0; i < len; ++i)
if (s[i] == '*') totChar++;
else totNum++;
if (totChar - totNum + 1 > 0) ans = totChar - totNum + 1;
int a[N * 5];
int curLen = len + ans;
memset(a, 0, sizeof(a));
if (ans > 0)
{
for (int i = ans + 1; i <= curLen; ++i)
if (s[i - 1 - ans] == '*') a[i] = 1;
}
else
{
for (int i = 1; i <= curLen; ++i)
if (s[i - 1] == '*') a[i] = 1;
}
if (!a[curLen])
{
int l = 1;
while (l <= curLen)
{
if (a[l]) break;
else l++;
}
swap(a[l], a[curLen]);
++ans;
}
int r = curLen, pos = 1, tot = 0;
while (pos <= curLen)
{
if (!a[pos])
{
tot++;
pos++;
}
else
{
if (tot < 2)
{
int p = -1;
for (int i = r; i >= 1 && p != -1; --i)
if (!a[i]) p = i;
swap(a[p], a[pos]);
ans++;
pos++;
tot++;
r = p - 1;
}
else
{
tot--;
pos++;
}
}
}
printf("%d\n", ans);
}
return 0;
}


版权声明:本文博客原创文章,博客,未经同意,不得转载。