poj_1144Network(tarjan求割点)

时间:2021-11-11 12:27:41

poj_1144Network(tarjan求割点)

标签: tarjan 割点割边模板


题目链接

Network

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 12356 Accepted: 5688

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is

possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure

occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated

by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5

5 1 2 3 4

0

6

2 1 3

5 4 6 2

0

0

Sample Output

1

2

Hint

You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.

Source

Central Europe 1996

题意:

求割点的个数,这里注意一下输入就可以了,注意这里是求的无向图的割点,注意注意

题解:

割点割边模板题

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN = 10010;
const int MAXM = 100010;
struct Edge{
int to;
int next;
bool cut;//标记是否为桥的标记
}edge[MAXM];
int head[MAXN];
int Ecnt;
int Low[MAXN],DFN[MAXN],Stack[MAXN];
int Index,top;
bool Instack[MAXN];
bool cut[MAXN];
int add_block[MAXN];
int bridge;
void init(){
Ecnt = 0;
memset(head,-1,sizeof(head));
memset(Low,0,sizeof(Low));
memset(DFN,0,sizeof(DFN));
memset(Stack,0,sizeof(Stack));
top = 0;
Index = 0;
memset(Instack,0,sizeof(Instack));
memset(cut, 0,sizeof(cut));
memset(add_block,0,sizeof(add_block));
} void add(int from, int to){
edge[Ecnt].to = to;
edge[Ecnt].next = head[from];
head[from] = Ecnt++; edge[Ecnt].to = from;
edge[Ecnt].next = head[to];
head[to] = Ecnt++;
}
void Tarjan(int u,int pre)
{
int v;
Low[u] = DFN[u] = ++Index;
Stack[top++] = u;
Instack[u] = 1;
int son = 0;
for(int i = head[u]; i!=-1; i = edge[i].next){
v = edge[i].to;
if(v == pre) continue;
if(!DFN[v]){
son++;
Tarjan(v,u);
if(Low[u]>Low[v]) Low[u] = Low[v];
//桥
//一条无向边(u,v)是桥,DFS(u)<Low(v)
if(Low[v]>DFN[u])
{
bridge++;
edge[i].cut = true;
edge[i^1].cut = true;//有向图和无向图唯一的区别就是这里。i和i^1是同一条边不同方向
}
//割点
//一个顶点u是割点,当且仅当满足(1)u为树根,且u有多余一个字数,
//(2)u不为树根,且满足存在(u,v)为桥,即DFS(u)<=Low(v)
if(u!=pre&&Low[v]>=DFN[u])//不是树根
{
cut[u] = true;
//printf("cnt = %d\n", u);
add_block[u]++;
}
}
else if(Low[u]>DFN[v])
Low[u] = DFN[v];
}
if(u==pre&&son>1) cut[u] = true;
if(u==pre)add_block[u] = son -1;//这个数组保存去掉这个点可以产生多少个联通分量
Instack[u] = false;
top--;
// printf("id = %d %d %d\n", u, DFN[u], Low[u]); } int main()
{
int n;
while(~scanf("%d",&n),n)
{
init();
int tm;
int x;
char ch;
while(scanf("%d",&x), x) {
while(scanf("%c", &ch)) {
if(ch == '\n') break;
scanf("%d", &tm);
add(x-1, tm-1);
// printf("(%d %d)\n", x, tm);
}
}//这个图的建图一定要注意
Tarjan(0,0);//调用的时候要注意,因为它是通过自身编号和父亲节点编号相同来【判断是否是根节点的
int ans = 0;
for(int i = 0; i < n; i++){
if(cut[i]==1) ans++;
}
printf("%d\n",ans);
}
return 0;
}