HDU 1576 A/B 暴力也能过。扩展欧几里得

时间:2022-08-17 04:22:57

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1147    Accepted Submission(s): 887

Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
 
Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
 
Output
对应每组数据输出(A/B)%9973。
 
Sample Input
2
1000 53
87 123456789
 
Sample Output
7922
6060
 
Author
 
 /*
a/b=x;
a=bx;
a%9973=n;
a-a/9973*9973=n;
bx-a/9973*9973=n; ax+by=c;
==>
a=b;
b=9973;
c=n; */ #include<stdio.h> __int64 Ex_GCD(__int64 a,__int64 b,__int64 &x,__int64 &y)
{
if(b==)
{
x=;
y=;
return a;
}
__int64 g=Ex_GCD(b,a%b,x,y);
__int64 hxl;
hxl=x-(a/b)*y;
x=y;
y=hxl;
return g;
} int main()
{
__int64 T,n,a,b,c,k,x,y;
while(scanf("%I64d",&T)>)
{
while(T--)
{
scanf("%I64d%I64d",&n,&b);
a=b;
c=n;
b=;
k=Ex_GCD(a,b,x,y);
x=x*(c/k);
b=b/k;
x=x%(b);
while(x<)
{
x=x+b;
}
printf("%I64d\n",x);
}
}
return ;
}