Find The Multiple 分类: 搜索 POJ 2015-08-09 15:19 3人阅读 评论(0) 收藏

时间:2023-01-19 22:39:47

Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 21851 Accepted: 8984 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2

6

19

0

Sample Output

10

100100100100100100

111111111111111111

Source

Dhaka 2002

刚开始看到的时候以为是大数,要用JAVA,可是渣渣不会JAVA,搜了一下题解,原来long long 就可以过,bfs飞过

#include <map>
#include <list>
#include <climits>
#include <cmath>
#include <queue>
#include <stack>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-9
#define LL unsigned long long
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CRR fclose(stdin)
#define CWW fclose(stdout)
#define RR freopen("input.txt","r",stdin)
#define WW freopen("output.txt","w",stdout) int n; long long bfs()
{
queue<long long>Q;
long long a;
Q.push(1);
while(!Q.empty())
{
a=Q.front();
Q.pop();
if(a%n==0)
{
return a;
}
Q.push(a*10);
Q.push(a*10+1);
}
return 0;
} int main()
{
while(scanf("%d",&n),n)
{
cout<<bfs()<<endl;
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。